diff mbox

[bug#50047,0/8] OpenCL updates

Message ID YRaHX7nFOyK9C8Z5@noor.fritz.box
State Accepted
Headers show

Commit Message

Lars-Dominik Braun Aug. 13, 2021, 2:53 p.m. UTC
Hi,

the following series updates several packages related to OpenCL. I built
and tested darktable (again), as well as example programs for
python-pyopencl using pocl and rocm-opencl-runtime.

Cheers,
Lars

Lars-Dominik Braun (8):
  gnu: opencl-headers: Update to 2021.06.30 and switch to CMake.
  gnu: opencl-clhpp: Update to 2.0.15.
  gnu: clinfo: Update to 3.0.21.02.21 and simplify package.
  gnu: Add opencl-icd-loader.
  gnu: ocl-icd: Replace with opencl-icd-loader.
  gnu: Add clpeak.
  gnu: python-pytools: Update to 2021.2.7.
  gnu: python-pyopencl: Update to 2021.2.6.

 gnu/packages/benchmark.scm |  29 +++++++
 gnu/packages/games.scm     |   2 +-
 gnu/packages/opencl.scm    | 150 +++++++++++++++----------------------
 gnu/packages/photo.scm     |   5 +-
 gnu/packages/rocm.scm      |   4 +-
 5 files changed, 96 insertions(+), 94 deletions(-)

Comments

Lars-Dominik Braun Aug. 27, 2021, 6:54 p.m. UTC | #1
Hi,

> the following series updates several packages related to OpenCL. I built
> and tested darktable (again), as well as example programs for
> python-pyopencl using pocl and rocm-opencl-runtime.
pushed as ac52d4b95cac6b2eae67f4188cfc2a1db46cfd6e and following.

Lars
diff mbox

Patch

From 111578540c9415511639bfb9df1b8822e768237c Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <lars@6xq.net>
Date: Wed, 11 Aug 2021 21:35:58 +0200
Subject: [PATCH 8/8] gnu: python-pyopencl: Update to 2021.2.6.

* gnu/packages/opencl.scm (python-pyopencl)[version]: Update to
2021.2.6.
[source]: Point to new git repository.
[#:phases]: Remove unused phases.
[inputs]: Use unversioned opencl-headers.
[propagated-inputs]: Remove unused inputs.
---
 gnu/packages/opencl.scm | 25 +++++--------------------
 1 file changed, 5 insertions(+), 20 deletions(-)

diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 70d917c11f..2d5ccf0105 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -364,44 +364,29 @@  A lexer, @code{pytools.lex}.
 (define-public python-pyopencl
   (package
     (name "python-pyopencl")
-    (version "2019.1.1")
+    (version "2021.2.6")
     (source
      (origin
-       ;; The tarball on PyPI lacks test programs such as
-       ;; 'pygpu_language_opencl.cpp' so fetch it from Git.
-       ;; XXX: The server at git.tiker.net is unreliable.
        (method git-fetch)
        (uri (git-reference
-             (url "http://git.tiker.net/trees/pyopencl.git")
+             (url "https://github.com/inducer/pyopencl.git")
              (commit (string-append "v" version))
              (recursive? #t)))
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "12q0rs8yla571vcfpsh0mfrjbdiayv0hi8r1rq0f178m3i3qjz80"))))
+         "1s2cls7avxvf753zzpx422ikslaxdnm8rz58zg7mal15yak0wv2x"))))
     (build-system python-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-before 'build 'set-home
-                    (lambda _
-                      ;; Some of the Python build scripts expect 'HOME' to be
-                      ;; set.
-                      (setenv "HOME" (getcwd))
-                      #t)))
-
-       ;; Tests in 'compyte/ndarray/setup_opencl.py' appear to rely on
-       ;; 'nvcc', which is not an option.
-       #:tests? #f))
+     `(#:tests? #f)) ; Tests cannot find pygpu_language_opencl.cpp
     (inputs
-     `(("opencl-headers" ,opencl-headers-1.2)   ;POCL only supports OpenCL 1.2
+     `(("opencl-headers" ,opencl-headers)
        ("pybind11" ,pybind11)
        ("opencl-icd-loader" ,opencl-icd-loader)))                     ;libOpenCL
     (propagated-inputs
      `(("python-appdirs" ,python-appdirs)
-       ("python-decorator" ,python-decorator)
        ("python-numpy" ,python-numpy)
        ("python-pytools" ,python-pytools)
-       ("python-six" ,python-six)
        ("python-mako" ,python-mako)))
     (home-page "http://mathema.tician.de/software/pyopencl")
     (synopsis "Python wrapper for OpenCL")
-- 
2.31.1