diff mbox series

[bug#49740,core-updates?] gnu: r-with-tests: Hardcode path to coreutils’ rm

Message ID YP5jX/7V0Pn4KLBy@noor.fritz.box
State Accepted
Headers show
Series [bug#49740,core-updates?] gnu: r-with-tests: Hardcode path to coreutils’ rm | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Lars-Dominik Braun July 26, 2021, 7:25 a.m. UTC
When running R in a container like this

	guix environment --no-cwd -C --ad-hoc r-minimal -- Rscript -e 'Sys.timezone()'

it would print an additional line

	sh: rm: command not found

before exiting.

* gnu/packages/statistics.scm (r-with-tests) [#:phases]: Add substitute*
to patch call to `rm` and rename phase to reflect what it does now.
---
 gnu/packages/statistics.scm | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

Comments

Ricardo Wurmus July 26, 2021, 10:50 a.m. UTC | #1
Hi,

this looks good to me.

Please push to a new “r-updates” branch based on top of “master”.
Lars-Dominik Braun July 26, 2021, 11:15 a.m. UTC | #2
Hi,

done, closing.

Lars
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index ce9f1bf888..7ba7d9f20d 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -213,12 +213,15 @@  This package also provides @command{xls2csv} to export Excel files to CSV.")
              (substitute* "src/library/base/makebasedb.R"
                (("compress = TRUE") "compress = FALSE"))
              #t))
-         (add-before 'configure 'patch-uname
+         (add-before 'configure 'patch-coreutils-paths
            (lambda* (#:key inputs #:allow-other-keys)
-             (let ((uname-bin (string-append (assoc-ref inputs "coreutils")
-                                             "/bin/uname")))
+             (let* ((coreutils (assoc-ref inputs "coreutils"))
+                   (uname-bin (string-append coreutils "/bin/uname"))
+                   (rm-bin (string-append coreutils "/bin/rm")))
                (substitute* "src/scripts/R.sh.in"
-                 (("uname") uname-bin)))
+                 (("uname") uname-bin))
+               (substitute* "src/unix/sys-std.c"
+                 (("rm -Rf ") (string-append rm-bin " -Rf "))))
              #t))
          (add-after 'unpack 'build-reproducibly
            (lambda _