diff mbox series

[bug#49451,20/20] Run indent-code.el on the packages i added

Message ID YOtjDK6kGsLM9r1Z@thunix.net
State New
Headers show
Series [bug#49451,01/20] gnu: rust-blake2: Update to 0.9 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

southerntofu July 11, 2021, 9:30 p.m. UTC
---
 gnu/packages/crates-io.scm | 574 ++++++++++++++++++-------------------
 gnu/packages/messaging.scm |  82 +++---
 2 files changed, 328 insertions(+), 328 deletions(-)

Comments

Xinglu Chen Aug. 1, 2021, 10:28 a.m. UTC | #1
On Sun, Jul 11 2021, southerntofu via Guix-patches via wrote:

> ---
>  gnu/packages/crates-io.scm | 574 ++++++++++++++++++-------------------
>  gnu/packages/messaging.scm |  82 +++---
>  2 files changed, 328 insertions(+), 328 deletions(-)

etc/indent-code.el should be run on each individual package before you
create one or more patches.  For example

  Write definition of package A
  Run etc/indent-code.el on package A
  Create the patch

or if there are multiple packages

  Write definition of package A
  Write definition of package B
  Run etc/indent-code.el on package A and B
  Create patches for package A and B
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f85b096547..f215bdee73 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5212,24 +5212,24 @@  streams in big-endian and little-endian formats.")
     (name "rust-blake2")
     (version "0.9.1")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "blake2" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "1x3qz692hfrxgw6cd94iiid6iqal2dwj6zv5137swpgg4l17598h"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "blake2" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1x3qz692hfrxgw6cd94iiid6iqal2dwj6zv5137swpgg4l17598h"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-crypto-mac" ,rust-crypto-mac-0.8)
-         ("rust-digest" ,rust-digest-0.9)
-         ("rust-opaque-debug" ,rust-opaque-debug-0.3))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-crypto-mac" ,rust-crypto-mac-0.8)
+        ("rust-digest" ,rust-digest-0.9)
+        ("rust-opaque-debug" ,rust-opaque-debug-0.3))))
     (home-page
-      "https://github.com/RustCrypto/hashes")
+     "https://github.com/RustCrypto/hashes")
     (synopsis "BLAKE2 hash functions")
     (description "BLAKE2 hash functions")
     (license (list license:expat license:asl2.0))))
@@ -7260,21 +7260,21 @@  used in argon2rs' bench suite.")
     (name "rust-case")
     (version "0.1.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "case" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "1hgc6fdg01qfh0qx5c50n717vh0xqvrlvxix8ksng5p291mid2z8"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "case" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1hgc6fdg01qfh0qx5c50n717vh0xqvrlvxix8ksng5p291mid2z8"))))
     (build-system cargo-build-system)
     (arguments `(#:skip-build? #t))
     (home-page
-      "https://github.com/SkylerLipthay/case")
+     "https://github.com/SkylerLipthay/case")
     (synopsis "Set of letter case string helpers")
     (description
-      "This package provides a set of letter case string helpers")
+     "This package provides a set of letter case string helpers")
     (license license:expat)))
 
 (define-public rust-cassowary-0.3
@@ -12681,28 +12681,28 @@  pattern for arbitrary structs.")
     (name "rust-derive-error")
     (version "0.0.4")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "derive-error" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "1j624ma4jw911yg3qqlvfybgk7614k2blhg6wgnb38wyn90882gc"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "derive-error" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1j624ma4jw911yg3qqlvfybgk7614k2blhg6wgnb38wyn90882gc"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-case" ,rust-case-0.1)
-         ("rust-quote" ,rust-quote-0.3)
-         ("rust-syn" ,rust-syn-0.11))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-case" ,rust-case-0.1)
+        ("rust-quote" ,rust-quote-0.3)
+        ("rust-syn" ,rust-syn-0.11))))
     (home-page
-      "https://github.com/rushmorem/derive-error")
+     "https://github.com/rushmorem/derive-error")
     (synopsis
-      "Derive macro for Error using macros 1.1")
+     "Derive macro for Error using macros 1.1")
     (description
-      "Derive macro for Error using macros 1.1")
+     "Derive macro for Error using macros 1.1")
     (license (list license:expat license:asl2.0))))
 
 (define-public rust-derive-error-chain-0.10
@@ -13726,22 +13726,22 @@  from macros.")
     (name "rust-downcast")
     (version "0.10.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "downcast" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "07bh0l95gwrzak6rj29v8kkm577d8vivxsxhqgscf64b4bq59d2b"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "downcast" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "07bh0l95gwrzak6rj29v8kkm577d8vivxsxhqgscf64b4bq59d2b"))))
     (build-system cargo-build-system)
     (arguments `(#:skip-build? #t))
     (home-page
-      "https://github.com/fkoep/downcast-rs")
+     "https://github.com/fkoep/downcast-rs")
     (synopsis
-      "Trait for downcasting trait objects back to their original types")
+     "Trait for downcasting trait objects back to their original types")
     (description
-      "Trait for downcasting trait objects back to their original types")
+     "Trait for downcasting trait objects back to their original types")
     (license license:expat)))
 
 (define-public rust-downcast-rs-1
@@ -15990,40 +15990,40 @@  streams.")
     (name "rust-flexi-logger")
     (version "0.15.12")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "flexi_logger" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "1gs2flpzjd4kr9jw614vaqxxz7fd56gqkr78j47q0ja1vfp3raxa"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "flexi_logger" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1gs2flpzjd4kr9jw614vaqxxz7fd56gqkr78j47q0ja1vfp3raxa"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-atty" ,rust-atty-0.2)
-         ("rust-chrono" ,rust-chrono-0.4)
-         ("rust-flate2" ,rust-flate2-1)
-         ("rust-glob" ,rust-glob-0.3)
-         ("rust-hostname" ,rust-hostname-0.3)
-         ("rust-lazy-static" ,rust-lazy-static-1)
-         ("rust-libc" ,rust-libc-0.2)
-         ("rust-log" ,rust-log-0.4)
-         ("rust-notify" ,rust-notify-4)
-         ("rust-regex" ,rust-regex-1)
-         ("rust-serde" ,rust-serde-1)
-         ("rust-serde-derive" ,rust-serde-derive-1)
-         ("rust-thiserror" ,rust-thiserror-1)
-         ("rust-toml" ,rust-toml-0.5)
-         ("rust-yansi" ,rust-yansi-0.5))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-atty" ,rust-atty-0.2)
+        ("rust-chrono" ,rust-chrono-0.4)
+        ("rust-flate2" ,rust-flate2-1)
+        ("rust-glob" ,rust-glob-0.3)
+        ("rust-hostname" ,rust-hostname-0.3)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-libc" ,rust-libc-0.2)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-notify" ,rust-notify-4)
+        ("rust-regex" ,rust-regex-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-derive" ,rust-serde-derive-1)
+        ("rust-thiserror" ,rust-thiserror-1)
+        ("rust-toml" ,rust-toml-0.5)
+        ("rust-yansi" ,rust-yansi-0.5))))
     (home-page
-      "https://github.com/emabee/flexi_logger")
+     "https://github.com/emabee/flexi_logger")
     (synopsis
-      "Easy-to-configure and flexible logger")
+     "Easy-to-configure and flexible logger")
     (description
-      "Easy-to-configure and flexible logger that writes logs to stderr and/or to files")
+     "Easy-to-configure and flexible logger that writes logs to stderr and/or to files")
     (license (list license:expat license:asl2.0))))
 
 (define-public rust-float-cmp-0.8
@@ -16457,22 +16457,22 @@  syntax, as used by HTML forms.")
     (name "rust-fragile")
     (version "1.0.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "fragile" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "1wlihmkjyhvl5rckal32p010piy1l15s6l81h7z31jcd971kk839"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fragile" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1wlihmkjyhvl5rckal32p010piy1l15s6l81h7z31jcd971kk839"))))
     (build-system cargo-build-system)
     (arguments `(#:skip-build? #t))
     (home-page
-      "https://github.com/mitsuhiko/rust-fragile")
+     "https://github.com/mitsuhiko/rust-fragile")
     (synopsis
-      "Provides wrapper types for sending non-send values to other threads")
+     "Provides wrapper types for sending non-send values to other threads")
     (description
-      "Provides wrapper types for sending non-send values to other threads")
+     "Provides wrapper types for sending non-send values to other threads")
     (license license:asl2.0)))
 
 (define-public rust-fragile-0.3
@@ -20146,26 +20146,26 @@  Derivation Function (HKDF).")
     (name "rust-hmac")
     (version "0.10.1")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "hmac" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "058yxq54x7xn0gk2vy9bl51r32c9z7qlcl2b80bjh3lk3rmiqi61"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hmac" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "058yxq54x7xn0gk2vy9bl51r32c9z7qlcl2b80bjh3lk3rmiqi61"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-crypto-mac" ,rust-crypto-mac-0.10)
-         ("rust-digest" ,rust-digest-0.9))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-crypto-mac" ,rust-crypto-mac-0.10)
+        ("rust-digest" ,rust-digest-0.9))))
     (home-page "https://github.com/RustCrypto/MACs")
     (synopsis
-      "Generic implementation of Hash-based Message Authentication Code (HMAC)")
+     "Generic implementation of Hash-based Message Authentication Code (HMAC)")
     (description
-      "Generic implementation of Hash-based Message Authentication Code (HMAC)")
+     "Generic implementation of Hash-based Message Authentication Code (HMAC)")
     (license (list license:expat license:asl2.0))))
 
 (define-public rust-hmac-0.8
@@ -20332,22 +20332,22 @@  Hash-based Message Authentication Code algorithm} for SHA1.")
     (name "rust-hsluv")
     (version "0.1.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "hsluv" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "0g5p4x9np7292fxinqj34vlys5v20hg5yqqr8vvqbw8xcl5l3rax"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hsluv" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0g5p4x9np7292fxinqj34vlys5v20hg5yqqr8vvqbw8xcl5l3rax"))))
     (build-system cargo-build-system)
     (arguments `(#:skip-build? #t))
     (home-page
-      "https://github.com/bb010g/rust-hsluv")
+     "https://github.com/bb010g/rust-hsluv")
     (synopsis
-      "Human-friendly HSL, Rust implementation (revision 4)")
+     "Human-friendly HSL, Rust implementation (revision 4)")
     (description
-      "Human-friendly HSL, Rust implementation (revision 4)")
+     "Human-friendly HSL, Rust implementation (revision 4)")
     (license license:expat)))
 
 (define-public rust-html5ever-0.25
@@ -22732,26 +22732,26 @@  byte slices for sets of ASCII characters or bytes.")
     (name "rust-jid")
     (version "0.9.2")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "jid" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "1s3dl38wwhnx0pbzm4cnwqmmr09nfg4nv6w4yl3cmbkc2n7xipma"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "jid" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1s3dl38wwhnx0pbzm4cnwqmmr09nfg4nv6w4yl3cmbkc2n7xipma"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-minidom" ,rust-minidom-0.13)
-         ("rust-serde" ,rust-serde-1))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-minidom" ,rust-minidom-0.13)
+        ("rust-serde" ,rust-serde-1))))
     (home-page "https://gitlab.com/xmpp-rs/xmpp-rs")
     (synopsis
-      "Crate which provides a Jid struct for Jabber IDs")
+     "Crate which provides a Jid struct for Jabber IDs")
     (description
-      "This package provides a crate which provides a Jid struct for Jabber IDs.")
+     "This package provides a crate which provides a Jid struct for Jabber IDs.")
     (license license:mpl2.0)))
 
 (define-public rust-jni-0.18
@@ -24361,24 +24361,24 @@  pairs in insertion order.")
     (name "rust-linked-hash-set")
     (version "0.1.4")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "linked_hash_set" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "124m7wiz9ah7ah58ckai413mzfglh3y1nz64qy1s676qlinnq627"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "linked_hash_set" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "124m7wiz9ah7ah58ckai413mzfglh3y1nz64qy1s676qlinnq627"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-linked-hash-map"
-          ,rust-linked-hash-map-0.5)
-         ("rust-serde" ,rust-serde-1))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-linked-hash-map"
+         ,rust-linked-hash-map-0.5)
+        ("rust-serde" ,rust-serde-1))))
     (home-page
-      "https://github.com/alexheretic/linked-hash-set")
+     "https://github.com/alexheretic/linked-hash-set")
     (synopsis "HashSet with insertion ordering")
     (description "HashSet with insertion ordering")
     (license license:asl2.0)))
@@ -26364,25 +26364,25 @@  file's MIME type by its extension.")
     (name "rust-minidom")
     (version "0.13.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "minidom" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "13k0ngkwgj0zgn0zkkklnj274q351mpyzjaglr0dviwz2k19499k"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "minidom" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "13k0ngkwgj0zgn0zkkklnj274q351mpyzjaglr0dviwz2k19499k"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-quick-xml" ,rust-quick-xml-0.20))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-quick-xml" ,rust-quick-xml-0.20))))
     (home-page "https://gitlab.com/xmpp-rs/xmpp-rs")
     (synopsis
-      "Small, simple DOM implementation on top of quick-xml")
+     "Small, simple DOM implementation on top of quick-xml")
     (description
-      "This package provides a small, simple DOM implementation on top of quick-xml")
+     "This package provides a small, simple DOM implementation on top of quick-xml")
     (license license:mpl2.0)))
 
 (define-public rust-miniz-oxide-0.4
@@ -26772,32 +26772,32 @@  IOCP and Async I/O abstractions.")
     (name "rust-mockall")
     (version "0.9.1")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "mockall" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "1m9kpv4523503v48ahyzk9g2rabvbjl70mlbkc8mkfzr4fni9mhq"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "mockall" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1m9kpv4523503v48ahyzk9g2rabvbjl70mlbkc8mkfzr4fni9mhq"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-cfg-if" ,rust-cfg-if-1)
-         ("rust-downcast" ,rust-downcast-0.10)
-         ("rust-fragile" ,rust-fragile-1)
-         ("rust-lazy-static" ,rust-lazy-static-1)
-         ("rust-mockall-derive" ,rust-mockall-derive-0.9)
-         ("rust-predicates" ,rust-predicates-1)
-         ("rust-predicates-tree" ,rust-predicates-tree-1))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-cfg-if" ,rust-cfg-if-1)
+        ("rust-downcast" ,rust-downcast-0.10)
+        ("rust-fragile" ,rust-fragile-1)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-mockall-derive" ,rust-mockall-derive-0.9)
+        ("rust-predicates" ,rust-predicates-1)
+        ("rust-predicates-tree" ,rust-predicates-tree-1))))
     (home-page "https://github.com/asomers/mockall")
     (synopsis
-      "Powerful mock object library for Rust
+     "Powerful mock object library for Rust
 ")
     (description
-      "This package provides a powerful mock object library for Rust
+     "This package provides a powerful mock object library for Rust
 ")
     (license (list license:expat license:asl2.0))))
 
@@ -26806,23 +26806,23 @@  IOCP and Async I/O abstractions.")
     (name "rust-mockall-derive")
     (version "0.9.1")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "mockall_derive" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "1snywdscj3chgs0xqr5700dsw2hy0qwd0s3kdk4nz85w6m327m2x"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "mockall_derive" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1snywdscj3chgs0xqr5700dsw2hy0qwd0s3kdk4nz85w6m327m2x"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-cfg-if" ,rust-cfg-if-1)
-         ("rust-proc-macro2" ,rust-proc-macro2-1)
-         ("rust-quote" ,rust-quote-1)
-         ("rust-syn" ,rust-syn-1))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-cfg-if" ,rust-cfg-if-1)
+        ("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-1))))
     (home-page "https://github.com/asomers/mockall")
     (synopsis "Procedural macros for Mockall
 ")
@@ -31258,29 +31258,29 @@  directory path to the provided path.")
     (name "rust-pbkdf2")
     (version "0.6.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "pbkdf2" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "0jjaapyawm5iqn97mmfj40dvipsy78cm80qcva28009l2zbw1f5k"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pbkdf2" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0jjaapyawm5iqn97mmfj40dvipsy78cm80qcva28009l2zbw1f5k"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-base64" ,rust-base64-0.13)
-         ("rust-crypto-mac" ,rust-crypto-mac-0.10)
-         ("rust-hmac" ,rust-hmac-0.10)
-         ("rust-rand" ,rust-rand-0.7)
-         ("rust-rand-core" ,rust-rand-core-0.5)
-         ("rust-rayon" ,rust-rayon-1)
-         ("rust-sha2" ,rust-sha2-0.9)
-         ("rust-subtle" ,rust-subtle-2))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-base64" ,rust-base64-0.13)
+        ("rust-crypto-mac" ,rust-crypto-mac-0.10)
+        ("rust-hmac" ,rust-hmac-0.10)
+        ("rust-rand" ,rust-rand-0.7)
+        ("rust-rand-core" ,rust-rand-core-0.5)
+        ("rust-rayon" ,rust-rayon-1)
+        ("rust-sha2" ,rust-sha2-0.9)
+        ("rust-subtle" ,rust-subtle-2))))
     (home-page
-      "https://github.com/RustCrypto/password-hashes/tree/master/pbkdf2")
+     "https://github.com/RustCrypto/password-hashes/tree/master/pbkdf2")
     (synopsis "Generic implementation of PBKDF2")
     (description "Generic implementation of PBKDF2")
     (license (list license:expat license:asl2.0))))
@@ -42178,25 +42178,25 @@  functions core functionality.")
     (name "rust-sha3")
     (version "0.9.1")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "sha3" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "02d85wpvz75a0n7r2da15ikqjwzamhii11qy9gqf6pafgm0rj4gq"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "sha3" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "02d85wpvz75a0n7r2da15ikqjwzamhii11qy9gqf6pafgm0rj4gq"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-block-buffer" ,rust-block-buffer-0.9)
-         ("rust-digest" ,rust-digest-0.9)
-         ("rust-keccak" ,rust-keccak-0.1)
-         ("rust-opaque-debug" ,rust-opaque-debug-0.3))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-block-buffer" ,rust-block-buffer-0.9)
+        ("rust-digest" ,rust-digest-0.9)
+        ("rust-keccak" ,rust-keccak-0.1)
+        ("rust-opaque-debug" ,rust-opaque-debug-0.3))))
     (home-page
-      "https://github.com/RustCrypto/hashes")
+     "https://github.com/RustCrypto/hashes")
     (synopsis "SHA-3 (Keccak) hash function")
     (description "SHA-3 (Keccak) hash function")
     (license (list license:expat license:asl2.0))))
@@ -49642,42 +49642,42 @@  stream-based WebSocket implementation.")
     (name "rust-tokio-xmpp")
     (version "3.0.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "tokio-xmpp" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "0f8s4gsv9zs6rlkc40jjglcm0prq10ypxszrwvpxhjbygbxrzb2n"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "tokio-xmpp" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0f8s4gsv9zs6rlkc40jjglcm0prq10ypxszrwvpxhjbygbxrzb2n"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-bytes" ,rust-bytes-1)
-         ("rust-futures" ,rust-futures-0.3)
-         ("rust-idna" ,rust-idna-0.2)
-         ("rust-log" ,rust-log-0.4)
-         ("rust-native-tls" ,rust-native-tls-0.2)
-         ("rust-rustc-version" ,rust-rustc-version-0.3)
-         ("rust-sasl" ,rust-sasl-0.5)
-         ("rust-tokio" ,rust-tokio-1)
-         ("rust-tokio-native-tls"
-          ,rust-tokio-native-tls-0.3)
-         ("rust-tokio-stream" ,rust-tokio-stream-0.1)
-         ("rust-tokio-util" ,rust-tokio-util-0.6)
-         ("rust-trust-dns-proto"
-          ,rust-trust-dns-proto-0.20)
-         ("rust-trust-dns-resolver"
-          ,rust-trust-dns-resolver-0.20)
-         ("rust-xml5ever" ,rust-xml5ever-0.16)
-         ("rust-xmpp-parsers" ,rust-xmpp-parsers-0.18))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-bytes" ,rust-bytes-1)
+        ("rust-futures" ,rust-futures-0.3)
+        ("rust-idna" ,rust-idna-0.2)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-native-tls" ,rust-native-tls-0.2)
+        ("rust-rustc-version" ,rust-rustc-version-0.3)
+        ("rust-sasl" ,rust-sasl-0.5)
+        ("rust-tokio" ,rust-tokio-1)
+        ("rust-tokio-native-tls"
+         ,rust-tokio-native-tls-0.3)
+        ("rust-tokio-stream" ,rust-tokio-stream-0.1)
+        ("rust-tokio-util" ,rust-tokio-util-0.6)
+        ("rust-trust-dns-proto"
+         ,rust-trust-dns-proto-0.20)
+        ("rust-trust-dns-resolver"
+         ,rust-trust-dns-resolver-0.20)
+        ("rust-xml5ever" ,rust-xml5ever-0.16)
+        ("rust-xmpp-parsers" ,rust-xmpp-parsers-0.18))))
     (home-page "https://gitlab.com/xmpp-rs/xmpp-rs")
     (synopsis
-      "Asynchronous XMPP for Rust with tokio")
+     "Asynchronous XMPP for Rust with tokio")
     (description
-      "Asynchronous XMPP for Rust with tokio")
+     "Asynchronous XMPP for Rust with tokio")
     (license license:mpl2.0)))
 
 (define-public rust-toml-0.5
@@ -55081,33 +55081,33 @@  parser.")
     (name "rust-xmpp-parsers")
     (version "0.18.1")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "xmpp-parsers" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "064bjmngy0abcp9wcms7h5b13rljr0isliy83csaa0j7xyjmpkq1"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "xmpp-parsers" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "064bjmngy0abcp9wcms7h5b13rljr0isliy83csaa0j7xyjmpkq1"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-base64" ,rust-base64-0.13)
-         ("rust-blake2" ,rust-blake2-0.9)
-         ("rust-chrono" ,rust-chrono-0.4)
-         ("rust-digest" ,rust-digest-0.9)
-         ("rust-jid" ,rust-jid-0.9)
-         ("rust-minidom" ,rust-minidom-0.13)
-         ("rust-sha-1" ,rust-sha-1-0.9)
-         ("rust-sha2" ,rust-sha2-0.9)
-         ("rust-sha3" ,rust-sha3-0.9))))
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-base64" ,rust-base64-0.13)
+        ("rust-blake2" ,rust-blake2-0.9)
+        ("rust-chrono" ,rust-chrono-0.4)
+        ("rust-digest" ,rust-digest-0.9)
+        ("rust-jid" ,rust-jid-0.9)
+        ("rust-minidom" ,rust-minidom-0.13)
+        ("rust-sha-1" ,rust-sha-1-0.9)
+        ("rust-sha2" ,rust-sha2-0.9)
+        ("rust-sha3" ,rust-sha3-0.9))))
     (home-page "https://gitlab.com/xmpp-rs/xmpp-rs")
     (synopsis
-      "Collection of parsers and serialisers for XMPP extensions")
+     "Collection of parsers and serialisers for XMPP extensions")
     (description
-      "Collection of parsers and serialisers for XMPP extensions")
+     "Collection of parsers and serialisers for XMPP extensions")
     (license license:mpl2.0)))
 
 (define-public rust-xshell-macros-0.1
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 6bfee2e15e..9d08347583 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3023,56 +3023,56 @@  API.  Mattermost is not required.")
     (name "aparte")
     (version "0.2.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "aparte" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "0qzg1052whjhcsz8n3s77kb4zvp7k0na3hikzkf5qa3z4g0hyvrp"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "aparte" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0qzg1052whjhcsz8n3s77kb4zvp7k0na3hikzkf5qa3z4g0hyvrp"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:cargo-inputs
-        (("rust-backtrace" ,rust-backtrace-0.3)
-         ("rust-bytes" ,rust-bytes-0.5)
-         ("rust-chrono" ,rust-chrono-0.4)
-         ("rust-derive-error" ,rust-derive-error-0.0.4)
-         ("rust-dirs" ,rust-dirs-2)
-         ("rust-flexi-logger" ,rust-flexi-logger-0.15)
-         ("rust-futures" ,rust-futures-0.3)
-         ("rust-fuzzy-matcher" ,rust-fuzzy-matcher-0.3)
-         ("rust-hsluv" ,rust-hsluv-0.1)
-         ("rust-linked-hash-map"
-          ,rust-linked-hash-map-0.5)
-         ("rust-linked-hash-set"
-          ,rust-linked-hash-set-0.1)
-         ("rust-log" ,rust-log-0.4)
-         ("rust-rand" ,rust-rand-0.8)
-         ("rust-rpassword" ,rust-rpassword-3)
-         ("rust-rust-crypto" ,rust-rust-crypto-0.2)
-         ("rust-serde" ,rust-serde-1)
-         ("rust-termion" ,rust-termion-1)
-         ("rust-textwrap" ,rust-textwrap-0.12)
-         ("rust-tokio" ,rust-tokio-1)
-         ("rust-tokio-xmpp" ,rust-tokio-xmpp-3)
-         ("rust-toml" ,rust-toml-0.5)
-         ("rust-unicode-segmentation"
-          ,rust-unicode-segmentation-1)
-         ("rust-uuid" ,rust-uuid-0.7)
-         ("rust-xmpp-parsers" ,rust-xmpp-parsers-0.18))
-        #:cargo-development-inputs
-        (("rust-mockall" ,rust-mockall-0.9))))
+     `(#:cargo-inputs
+       (("rust-backtrace" ,rust-backtrace-0.3)
+        ("rust-bytes" ,rust-bytes-0.5)
+        ("rust-chrono" ,rust-chrono-0.4)
+        ("rust-derive-error" ,rust-derive-error-0.0.4)
+        ("rust-dirs" ,rust-dirs-2)
+        ("rust-flexi-logger" ,rust-flexi-logger-0.15)
+        ("rust-futures" ,rust-futures-0.3)
+        ("rust-fuzzy-matcher" ,rust-fuzzy-matcher-0.3)
+        ("rust-hsluv" ,rust-hsluv-0.1)
+        ("rust-linked-hash-map"
+         ,rust-linked-hash-map-0.5)
+        ("rust-linked-hash-set"
+         ,rust-linked-hash-set-0.1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-rand" ,rust-rand-0.8)
+        ("rust-rpassword" ,rust-rpassword-3)
+        ("rust-rust-crypto" ,rust-rust-crypto-0.2)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-termion" ,rust-termion-1)
+        ("rust-textwrap" ,rust-textwrap-0.12)
+        ("rust-tokio" ,rust-tokio-1)
+        ("rust-tokio-xmpp" ,rust-tokio-xmpp-3)
+        ("rust-toml" ,rust-toml-0.5)
+        ("rust-unicode-segmentation"
+         ,rust-unicode-segmentation-1)
+        ("rust-uuid" ,rust-uuid-0.7)
+        ("rust-xmpp-parsers" ,rust-xmpp-parsers-0.18))
+       #:cargo-development-inputs
+       (("rust-mockall" ,rust-mockall-0.9))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
      `(("openssl" ,openssl)))
     (home-page
-      "https://github.com/paulfariello/aparte")
+     "https://github.com/paulfariello/aparte")
     (synopsis
-      "Simple XMPP console client written in Rust and inspired by Profanity")
+     "Simple XMPP console client written in Rust and inspired by Profanity")
     (description
-      "Simple XMPP console client written in Rust and inspired by Profanity")
+     "Simple XMPP console client written in Rust and inspired by Profanity")
     (license license:mpl2.0)))
 
 ;;; messaging.scm ends here