diff mbox series

[bug#49451,11/20] gnu: rust-pbkdf2: Update to 0.6

Message ID YOti2uf3P812X5tw@thunix.net
State New
Headers show
Series [bug#49451,01/20] gnu: rust-blake2: Update to 0.9 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

southerntofu July 11, 2021, 9:30 p.m. UTC
---
 gnu/packages/crates-io.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Xinglu Chen Aug. 1, 2021, 10:17 a.m. UTC | #1
On Sun, Jul 11 2021, southerntofu via Guix-patches via wrote:

> ---
>  gnu/packages/crates-io.scm | 32 ++++++++++++++++++++++++++++++++
>  1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index b60d07c15b..b65ea9568f 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -31163,6 +31163,38 @@ path.Clean.")
>  directory path to the provided path.")
>      (license (list license:asl2.0 license:expat))))
>  
> +(define-public rust-pbkdf2-0.6
> +  (package
> +    (name "rust-pbkdf2")
> +    (version "0.6.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (crate-uri "pbkdf2" version))
> +        (file-name
> +          (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "0jjaapyawm5iqn97mmfj40dvipsy78cm80qcva28009l2zbw1f5k"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +      `(#:skip-build?
> +        #t
> +        #:cargo-inputs
> +        (("rust-base64" ,rust-base64-0.13)
> +         ("rust-crypto-mac" ,rust-crypto-mac-0.10)
> +         ("rust-hmac" ,rust-hmac-0.10)
> +         ("rust-rand" ,rust-rand-0.7)
> +         ("rust-rand-core" ,rust-rand-core-0.5)
> +         ("rust-rayon" ,rust-rayon-1)
> +         ("rust-sha2" ,rust-sha2-0.9)
> +         ("rust-subtle" ,rust-subtle-2))))
> +    (home-page
> +      "https://github.com/RustCrypto/password-hashes/tree/master/pbkdf2")
> +    (synopsis "Generic implementation of PBKDF2")
> +    (description "Generic implementation of PBKDF2")

Full sentence.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b60d07c15b..b65ea9568f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31163,6 +31163,38 @@  path.Clean.")
 directory path to the provided path.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-pbkdf2-0.6
+  (package
+    (name "rust-pbkdf2")
+    (version "0.6.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "pbkdf2" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0jjaapyawm5iqn97mmfj40dvipsy78cm80qcva28009l2zbw1f5k"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-base64" ,rust-base64-0.13)
+         ("rust-crypto-mac" ,rust-crypto-mac-0.10)
+         ("rust-hmac" ,rust-hmac-0.10)
+         ("rust-rand" ,rust-rand-0.7)
+         ("rust-rand-core" ,rust-rand-core-0.5)
+         ("rust-rayon" ,rust-rayon-1)
+         ("rust-sha2" ,rust-sha2-0.9)
+         ("rust-subtle" ,rust-subtle-2))))
+    (home-page
+      "https://github.com/RustCrypto/password-hashes/tree/master/pbkdf2")
+    (synopsis "Generic implementation of PBKDF2")
+    (description "Generic implementation of PBKDF2")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-pbkdf2-0.4
   (package
     (name "rust-pbkdf2")