diff mbox series

[bug#49451,16/20] gnu: Add rust-jid

Message ID YOti+gMC7h8B8QLV@thunix.net
State New
Headers show
Series [bug#49451,01/20] gnu: rust-blake2: Update to 0.9 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

southerntofu July 11, 2021, 9:30 p.m. UTC
---
 gnu/packages/crates-io.scm | 29 ++++++++++++++++++++++++++++-
 1 file changed, 28 insertions(+), 1 deletion(-)

Comments

Xinglu Chen Aug. 1, 2021, 10:23 a.m. UTC | #1
On Sun, Jul 11 2021, southerntofu via Guix-patches via wrote:

> ---
>  gnu/packages/crates-io.scm | 29 ++++++++++++++++++++++++++++-
>  1 file changed, 28 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 44ae54f84c..f2e32d6172 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -22727,6 +22727,33 @@ primitives to an @code{io::Write}.")
>  byte slices for sets of ASCII characters or bytes.")
>      (license license:expat)))
>  
> +(define-public rust-jid-0.9
> +  (package
> +    (name "rust-jid")
> +    (version "0.9.2")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (crate-uri "jid" version))
> +        (file-name
> +          (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "1s3dl38wwhnx0pbzm4cnwqmmr09nfg4nv6w4yl3cmbkc2n7xipma"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +      `(#:skip-build?
> +        #t
> +        #:cargo-inputs
> +        (("rust-minidom" ,rust-minidom-0.13)
> +         ("rust-serde" ,rust-serde-1))))
> +    (home-page "https://gitlab.com/xmpp-rs/xmpp-rs")
> +    (synopsis
> +      "Crate which provides a Jid struct for Jabber IDs")
> +    (description
> +      "This package provides a crate which provides a Jid struct for Jabber IDs.")
> +    (license license:mpl2.0)))
> +
>  (define-public rust-jni-0.18
>    (package
>      (name "rust-jni")
> @@ -39611,7 +39638,7 @@ motivation for writing this library.
>      (synopsis
>        "Crate for SASL authentication. Currently only does the client side")
>      (description
> -      "This package provides a crate for SASL authentication.  Currently only does the client side")
> +      "Crate for SASL authentication.  Currently only does the client side")
>      (license license:lgpl3+)))

This hunk should probably be dropped.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 44ae54f84c..f2e32d6172 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22727,6 +22727,33 @@  primitives to an @code{io::Write}.")
 byte slices for sets of ASCII characters or bytes.")
     (license license:expat)))
 
+(define-public rust-jid-0.9
+  (package
+    (name "rust-jid")
+    (version "0.9.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "jid" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1s3dl38wwhnx0pbzm4cnwqmmr09nfg4nv6w4yl3cmbkc2n7xipma"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-minidom" ,rust-minidom-0.13)
+         ("rust-serde" ,rust-serde-1))))
+    (home-page "https://gitlab.com/xmpp-rs/xmpp-rs")
+    (synopsis
+      "Crate which provides a Jid struct for Jabber IDs")
+    (description
+      "This package provides a crate which provides a Jid struct for Jabber IDs.")
+    (license license:mpl2.0)))
+
 (define-public rust-jni-0.18
   (package
     (name "rust-jni")
@@ -39611,7 +39638,7 @@  motivation for writing this library.
     (synopsis
       "Crate for SASL authentication. Currently only does the client side")
     (description
-      "This package provides a crate for SASL authentication.  Currently only does the client side")
+      "Crate for SASL authentication.  Currently only does the client side")
     (license license:lgpl3+)))
 
 (define-public rust-scan-fmt-0.2