diff mbox series

[bug#49575] Add date2name

Message ID YNMAEZWdRC39gDCVHBz_cniWC4i4jHHBfWyp8ELtjLIS108av5r4134bqogTVLaI-9SUoE2FIiF4yufNclwGj-r_T_Sj5ZdNZVxzAP_m-U4=@protonmail.com
State Accepted
Headers show
Series [bug#49575] Add date2name | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 15, 2021, 4:05 p.m. UTC
---
index d8c3fbec07..ac9a5f940d 100644
--
2.31.1
diff mbox series

Patch

--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -105,6 +105,7 @@ 
 ;;; Copyright © 2021 Danial Behzadi <dani.behzi@ubuntu.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -904,6 +905,37 @@  iotop, uptime, pidof, tty, taskset, pmap.")
     (properties `((python2-variant . ,(delay python2-psutil))))
     (license license:bsd-3)))

+(define-public python-date2name
+(package
+  (name "date2name")
+  (version "6c8f37277e8ec82aa50f90b8921422be30c4e798")
+  (source (origin
+            (method git-fetch)
+            (uri
+	      (git-reference
+		(url "https://github.com/novoid/date2name")
+		(commit version)))
+            (sha256
+             (base32
+              "1vq96b7n16d932nyfhnzwdwxff0zrqanidmwr4cxj2p67ad9y3w7"))))
+  (build-system python-build-system)
+  (arguments
+    `(#:tests? #f
+      #:phases
+      (modify-phases %standard-phases
+	(delete 'build)
+	(replace 'install
+	 (lambda* (#:key outputs #:allow-other-keys)
+	  (let* ((bindir (string-append (assoc-ref outputs "out") "/bin"))
+		 (binary (string-append bindir "/date2name")))
+	    (mkdir-p bindir)
+	    (copy-file "date2name/__init__.py" binary)
+	    (chmod binary #o555)))))))
+  (synopsis "Handling time-stamps and date-stamps in file names")
+  (description "Per default, date2name gets the modification time of matching files and directories and adds a datestamp in standard ISO 8601+ format YYYY-MM-DD (http://datestamps.org/index.shtml) at the beginning of the file- or directoryname.")
+  (home-page "https://github.com/novoid/date2name")
+  (license license:gpl3)))
+
 (define-public python2-psutil
   (let ((base (package-with-python2 (strip-python2-variant python-psutil))))
     (package/inherit base