diff mbox series

[bug#48292] - updated lisp library unix-opts.

Message ID YJbM/5D9H/Uwj+w2@kurosawa.casa.net
State Accepted
Headers show
Series [bug#48292] - updated lisp library unix-opts. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

cage May 8, 2021, 5:40 p.m. UTC
Hi!

I found this library outdated, this patch makes guix uses a commit with
new features added.

Bye!
C.

PS: please ignore my previous patch (#48291) for this library as there is a syntax
error :(


---
 gnu/packages/lisp-xyz.scm | 40 ++++++++++++++++++++-------------------
 1 file changed, 21 insertions(+), 19 deletions(-)

Comments

cage Dec. 1, 2021, 10:46 a.m. UTC | #1
Hi!

As there has not been any response from upstream, i wonder if this decision can be reconsidered and the git version of 'unix-opts' packaged.

The reason for this request is because the gemini browser tinmop (packaged in guix) does not works with such older version of 'unix-opts'.

Thanks in advance!
C.
Guillaume Le Vaillant Dec. 1, 2021, 12:29 p.m. UTC | #2
Patch pushed as 8e7e839c98102a79b5804b39e3cfb58e94687d97 with a modified
commit message.
Thanks.

We'll switch back to using a tag if upstream decides to make one some
day.
cage Dec. 1, 2021, 4:08 p.m. UTC | #3
On Wed, Dec 01, 2021 at 12:29:50PM +0000, Guillaume Le Vaillant wrote:
> Patch pushed as 8e7e839c98102a79b5804b39e3cfb58e94687d97 with a modified
> commit message.
> Thanks.
> 
> We'll switch back to using a tag if upstream decides to make one some
> day.

That's a great news for me, thanks!

I am preparing a few patches for other library the new version of tinmop needs, i believe updating these libraries could be useful for other people too! :)
Bye!
C.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0824fa1d82..e267840ffe 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3276,31 +3276,33 @@  settings ensure a very simple mode of operation, similar to that provided by
   (sbcl-package->ecl-package sbcl-cl-json))
 
 (define-public sbcl-unix-opts
-  (package
-    (name "sbcl-unix-opts")
-    (version "0.1.7")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/libre-man/unix-opts")
-             (commit version)))
-       (file-name (git-file-name "unix-opts" version))
-       (sha256
-        (base32
-         "08djdi1ard09fijb7w9bdmhmwd98b1hzmcnjw9fqjiqa0g3b44rr"))))
-    (build-system asdf-build-system/sbcl)
-    (home-page "https://github.com/hankhero/cl-json")
-    (synopsis "Unix-style command line options parser")
-    (description
-     "This is a minimalistic parser of command line options.  The main
+  (let ((commit "0e61f34b2ecf62288437810d4abb31e572048b04")
+        (revision "1"))
+    (package
+      (name "sbcl-unix-opts")
+      (version (git-version "0.1.7" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/libre-man/unix-opts")
+               (commit commit)))
+         (file-name (git-file-name "unix-opts" version))
+         (sha256
+          (base32
+           "16mcqpzwrz808p9n3wwl99ckg3hg7yihw08y1i4l7c92aldbkasq"))))
+      (build-system asdf-build-system/sbcl)
+      (home-page "https://github.com/hankhero/cl-json")
+      (synopsis "Unix-style command line options parser")
+      (description
+       "This is a minimalistic parser of command line options.  The main
 advantage of the library is the ability to concisely define command line
 options once and then use this definition for parsing and extraction of
 command line arguments, as well as printing description of command line
 options (you get --help for free).  This way you don't need to repeat
 yourself.  Also, @command{unix-opts} doesn't depend on anything and
 precisely controls the behavior of the parser via Common Lisp restarts.")
-    (license license:expat)))
+      (license license:expat))))
 
 (define-public cl-unix-opts
   (sbcl-package->cl-source-package sbcl-unix-opts))