diff mbox series

[bug#48126] Add package for vim-solarized

Message ID YJG0+36fywEZ4cjT@hellebore
State Accepted
Headers show
Series [bug#48126] Add package for vim-solarized | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Tissevert May 4, 2021, 8:56 p.m. UTC
Hello !

Thanks a lot for all your feedback.

It took me a little while but I think I've improved my first patch proposal. I
had tried to indent the code automatically like mentioned in the video tutorial
using etc/indent-code.el but obviously this had failed. Maybe I overwrote the
changes with vim ? Anyway, I tried doing it again but there are many other
badly indented blocks in the rest of the file so it is hard to do and retain
only what is in my new package. So I've done it twice during the process, but
it could still be a little weird.

I changed the source to use the main «heavy» repos, and since it has a release
tag but the actual commit corresponding to this tag is a little behind the
current state (I checked the diff, it has changes to the vim files, not just
the documentation) so I used the latest commit as target to be sure the most
recent changes were included in the package even though I still call it by the
name of the most recent tag.

So here goes.

Kind regards,

Tissevert


Le Sat, May 01, 2021 at 01:27:19AM +0200, Tobias Geerinckx-Rice a écrit :
> Well that diff got börked to hell.  Here it is again.
> 
> Kind regards,
> 
> T G-R
>
From e310e94869cfa274d0699ab97c60835dab6fa5eb Mon Sep 17 00:00:00 2001
From: Tissevert <tissevert+guix@marvid.fr>
Date: Tue, 4 May 2021 22:43:25 +0200
Subject: [PATCH] Update version, indentation and description

---
 gnu/packages/vim.scm | 53 ++++++++++++++++++++++++++------------------
 1 file changed, 32 insertions(+), 21 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 477c15b9aa..6fb79851b8 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -581,28 +581,39 @@  are detected, the user is notified.")
     (license license:wtfpl2)))
 
 (define-public vim-solarized
-  (package
-    (name "vim-solarized")
-    (version "v1.0.0beta1")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
+  (let ((commit "62f656a02f93c5190a8753159e34b385588d5ff3")
+        (revision "1"))
+    (package
+      (name "vim-solarized")
+      (version (git-version "v1.0.0beta1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
                (url "https://github.com/altercation/vim-colors-solarized")
-               (commit "528a59f26d12278698bb946f8fb82a63711eec21")))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "05d3lmd1shyagvr3jygqghxd3k8a4vp32723fvxdm57fdrlyzcm1"))))
-    (build-system copy-build-system)
-    (arguments
-     '(#:install-plan
-       '(("colors" "share/vim/vimfiles/")
-         ("doc" "share/vim/vimfiles/"))))
-    (home-page "https://github.com/altercation/vim-colors-solarized")
-    (synopsis "Solarized Colorscheme for Vim")
-    (description "Precision colors for machines and people")
-    (license license:bsd-3)))
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0001mz5v3a8zvi3gzmxhi3yrsb6hs7qf6i497arsngnvj2cwn61d"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan
+         '(("vim-colors-solarized/colors" "share/vim/vimfiles/")
+           ("vim-colors-solarized/doc" "share/vim/vimfiles/"))))
+      (home-page "https://github.com/altercation/vim-colors-solarized")
+      (synopsis "Solarized color scheme for Vim")
+      (description
+	   "Solarized is a 16-color palette comprising 8 monotones and 8 accent
+colors.  It was designed for use with both terminal and GUI applicatins, and
+has a dark and a light mode.
+
+Based on CIELAB lightness relationships between colors, this theme reduces
+brightness contrast but retains contrasting hues based on colorwheel relations
+for syntax highlighting readability.
+
+It retains the same selective contrast relationships and overall feel when
+switching between the light and dark background modes.")
+      (license license:expat))))
 
 (define-public editorconfig-vim
   (package