diff mbox series

[bug#48126] Add package for vim-solarized

Message ID YJ6uzf8fHcTJwC+m@hellebore
State Accepted
Headers show
Series [bug#48126] Add package for vim-solarized | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Tissevert May 14, 2021, 5:10 p.m. UTC
Hey,

This time I think the 2nd version of the patch has the right format. Actually
it's kind of a 3rd version because there was still an indentation problem (tabs
had creeped undected as far as my package's description) and a repetition in
the text.

And I have no idea why using etc/indent-code.el had broken the whole file last
time, it's worked fine and has modified only my region this time. So, it was
still useful practice for me : ) And I really hope it's good this time : )

Kind regards,

Tissevert

Le Tue, May 04, 2021 at 10:56:27PM +0200, Tissevert a écrit :
> Hello !
> 
> Thanks a lot for all your feedback.
> 
> It took me a little while but I think I've improved my first patch proposal. I
> had tried to indent the code automatically like mentioned in the video tutorial
> using etc/indent-code.el but obviously this had failed. Maybe I overwrote the
> changes with vim ? Anyway, I tried doing it again but there are many other
> badly indented blocks in the rest of the file so it is hard to do and retain
> only what is in my new package. So I've done it twice during the process, but
> it could still be a little weird.
> 
> I changed the source to use the main «heavy» repos, and since it has a release
> tag but the actual commit corresponding to this tag is a little behind the
> current state (I checked the diff, it has changes to the vim files, not just
> the documentation) so I used the latest commit as target to be sure the most
> recent changes were included in the package even though I still call it by the
> name of the most recent tag.
> 
> So here goes.
> 
> Kind regards,
> 
> Tissevert
> 
>
From 23f26c93fca3a5468774e419e07a9efb82339214 Mon Sep 17 00:00:00 2001
From: Tissevert <tissevert+guix@marvid.fr>
Date: Fri, 30 Apr 2021 19:04:35 +0200
Subject: [PATCH] Add package for vim-solarized

---
 gnu/packages/vim.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Thiago Jung Bauermann May 14, 2021, 6:25 p.m. UTC | #1
Hello Tissevert,

Em sexta-feira, 14 de maio de 2021, às 14:10:28 -03, Tissevert escreveu:
> Hey,
> 
> This time I think the 2nd version of the patch has the right format.
> Actually it's kind of a 3rd version because there was still an
> indentation problem (tabs had creeped undected as far as my package's
> description) and a repetition in the text.
> 
> And I have no idea why using etc/indent-code.el had broken the whole file
> last time, it's worked fine and has modified only my region this time.
> So, it was still useful practice for me : ) And I really hope it's good
> this time : )

I can't comment on the package itself, but I hope you don't mind me 
pointing out a minor nit:

> +       "Solarized is a 16-color palette comprising 8 monotones and 8
> accent +colors.  It was designed for use with both terminal and GUI
> applicatins, and +has a dark and a light mode.

Typo: applications
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 47ac984fc7..9e1eaa7fbd 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2019, 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 Tissevert <tissevert+guix@marvid.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -579,6 +580,41 @@  are detected, the user is notified.")
     (home-page "https://github.com/vim-syntastic/syntastic")
     (license license:wtfpl2)))
 
+(define-public vim-solarized
+  (let ((commit "62f656a02f93c5190a8753159e34b385588d5ff3")
+        (revision "1"))
+    (package
+      (name "vim-solarized")
+      (version (git-version "v1.0.0beta1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/altercation/vim-colors-solarized")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0001mz5v3a8zvi3gzmxhi3yrsb6hs7qf6i497arsngnvj2cwn61d"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan
+         '(("vim-colors-solarized/colors" "share/vim/vimfiles/")
+           ("vim-colors-solarized/doc" "share/vim/vimfiles/"))))
+      (home-page "https://github.com/altercation/vim-colors-solarized")
+      (synopsis "Solarized color scheme for Vim")
+      (description
+       "Solarized is a 16-color palette comprising 8 monotones and 8 accent
+colors.  It was designed for use with both terminal and GUI applicatins, and
+has a dark and a light mode.
+
+Based on CIELAB lightness relationships between colors, this theme reduces
+brightness contrast but retains contrasting hues based on colorwheel relations
+for syntax highlighting readability.
+
+It keeps the same selective contrast relationships and overall feel when
+switching between the light and dark background modes.")
+      (license license:expat))))
+
 (define-public editorconfig-vim
   (package
     (name "editorconfig-vim")