diff mbox series

[bug#62635,2/2] gnu: geary: Use g-expressions.

Message ID YIiOFmWCGkWU4NO4vA5R_uBcY_79jOhsFZ3D46HHMKKUgyuXl0zHNbmyRi4T0FTc17E0KLthNyKhh_UFQgzLVimhei2a7JupZpl7ufRsV0A=@protonmail.com
State New
Headers show
Series gnu: geary: Add missing dependency, use g-expressions. | expand

Commit Message

J. Sims April 3, 2023, 2:01 a.m. UTC
Empty Message
diff mbox series

Patch

From 4b10d7f81c379f47ba9c83b62d59d5c3727b2df1 Mon Sep 17 00:00:00 2001
From: Juliana Sims <jtsims@protonmail.com>
Date: Sun, 2 Apr 2023 21:51:31 -0400
Subject: [PATCH 2/2] gnu: geary: Use g-expressions.

* gnu/packages/gnome.scm (geary): Use g-expressions.
---
 gnu/packages/gnome.scm | 143 ++++++++++++++++++++---------------------
 1 file changed, 70 insertions(+), 73 deletions(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 515a242ed0..acdfbb7d59 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12604,79 +12604,76 @@  (define-public geary
                 "04hvw86r8sczvjm1z3ls5y5y5h6nyfb648rjkfx05ib00mqq5v1x"))))
     (build-system meson-build-system)
     (arguments
-     `(#:glib-or-gtk? #t
-       #:configure-flags
-       '("-Dprofile=release")
-       #:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'disable-failing-tests
-                    (lambda _
-                      (substitute* "test/test-client.vala"
-                        (("client.add_suite\\(new Application.CertificateManagerTest\\(\\).suite\\);")
-                         ""))))
-                  (add-after 'unpack 'generate-vapis
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      ;; It’s not possible to generate the GMime vapi, because
-                      ;; there’s custom metadata that gmime didn’t
-                      ;; install. Thus, the vapi should be built and installed
-                      ;; with gmime.
-                      (define gmime
-                        (assoc-ref inputs "gmime"))
-                      (copy-file (string-append gmime "/share/vala/vapi/gmime-3.0.vapi")
-                                 "bindings/vapi/gmime-3.0.vapi")))
-                  (add-after 'unpack 'disable-postinstall-script
-                    (lambda _
-                      (substitute* "build-aux/post_install.py"
-                        (("gtk-update-icon-cache")
-                         "true"))))
-                  (add-before 'check 'setup-home
-                    (lambda _
-                      ;; Tests require a writable HOME.
-                      (setenv "HOME" (getcwd))))
-                  (add-before 'check 'setup-xvfb
-                    (lambda _
-                      (system "Xvfb :1 &")
-                      (setenv "DISPLAY" ":1"))))))
-    (inputs
-     (list enchant
-           evolution-data-server
-           folks-with-libsoup2
-           gcr
-           glib
-           gmime
-           gnome-online-accounts-3.44
-           gsettings-desktop-schemas
-           gspell
-           gsound
-           gtk+
-           iso-codes
-           json-glib
-           libcanberra
-           libgee
-           libhandy
-           libpeas
-           libsecret
-           libstemmer
-           libunwind
-           sqlite
-           webkitgtk-with-libsoup2
-           ytnef))
-    (native-inputs
-     (list appstream-glib
-           cmake-minimal
-           desktop-file-utils
-           gettext-minimal
-           glib
-           `(,glib "bin")
-           gmime
-           gobject-introspection
-           gsettings-desktop-schemas
-           itstool
-           libarchive
-           libxml2
-           pkg-config
-           python-minimal
-           vala
-           xorg-server-for-tests))
+     (list #:glib-or-gtk? #t
+           #:configure-flags #~(list "-Dprofile=release")
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'disable-failing-tests
+                          (lambda _
+                            (substitute* "test/test-client.vala"
+                              (("client.add_suite\\(new Application.CertificateManagerTest\\(\\).suite\\);")
+                               ""))))
+                        (add-after 'unpack 'generate-vapis
+                          (lambda _
+                            ;; It’s not possible to generate the GMime vapi, because
+                            ;; there’s custom metadata that gmime didn’t
+                            ;; install. Thus, the vapi should be built and installed
+                            ;; with gmime.
+                            (copy-file (string-append #$gmime
+                                        "/share/vala/vapi/gmime-3.0.vapi")
+                                       "bindings/vapi/gmime-3.0.vapi")))
+                        (add-after 'unpack 'disable-postinstall-script
+                          (lambda _
+                            (substitute* "build-aux/post_install.py"
+                              (("gtk-update-icon-cache")
+                               "true"))))
+                        (add-before 'check 'setup-home
+                          (lambda _
+                            ;; Tests require a writable HOME.
+                            (setenv "HOME"
+                                    (getcwd))))
+                        (add-before 'check 'setup-xvfb
+                          (lambda _
+                            (system "Xvfb :1 &")
+                            (setenv "DISPLAY" ":1"))))))
+    (inputs (list enchant
+                  evolution-data-server
+                  folks-with-libsoup2
+                  gcr
+                  glib
+                  gmime
+                  gnome-online-accounts-3.44
+                  gsettings-desktop-schemas
+                  gspell
+                  gsound
+                  gtk+
+                  iso-codes
+                  json-glib
+                  libcanberra
+                  libgee
+                  libhandy
+                  libpeas
+                  libsecret
+                  libstemmer
+                  libunwind
+                  sqlite
+                  webkitgtk-with-libsoup2
+                  ytnef))
+    (native-inputs (list appstream-glib
+                         cmake-minimal
+                         desktop-file-utils
+                         gettext-minimal
+                         glib
+                         `(,glib "bin")
+                         gmime
+                         gobject-introspection
+                         gsettings-desktop-schemas
+                         itstool
+                         libarchive
+                         libxml2
+                         pkg-config
+                         python-minimal
+                         vala
+                         xorg-server-for-tests))
     (synopsis "GNOME email application built around conversations")
     (description
      "Geary collects related messages together into conversations,
-- 
2.39.2