diff mbox series

[bug#48017] - added 'telescope' gemini client with a terminal interface.

Message ID YIVva04T5jA/inAI@kurosawa.casa.net
State Accepted
Headers show
Series [bug#48017] - added 'telescope' gemini client with a terminal interface. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

cage April 25, 2021, 1:32 p.m. UTC
---
 gnu/packages/web-browsers.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou June 12, 2021, 9:17 p.m. UTC | #1
Hello,

cage <cage-dev@twistfold.it> writes:

> +(define-public telescope
> +  (package
> +    (name "telescope")
> +    (version "0.1.1")

Thank you. I updated it to 0.2, expounded the description into a full
sentence and applied your patch.

Regards,
cage June 12, 2021, 9:31 p.m. UTC | #2
On Sat, Jun 12, 2021 at 11:17:45PM +0200, Nicolas Goaziou wrote:

Hi!

[...]

> Thank you. I updated it to 0.2, expounded the description into a full
> sentence and applied your patch.

Thanks a lot!!
C.
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 50c3e69321..8e8895ae2e 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -907,3 +907,26 @@  http, and https via third-party applications.")
 interface.")
     (home-page "https://www.autistici.org/interzona/tinmop.html")
     (license license:gpl3+)))
+
+(define-public telescope
+  (package
+    (name "telescope")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/omar-polo/telescope/releases/download/0.1.1/telescope-"
+			   version
+			   ".tar.gz"))
+       (sha256 (base32 "04rzpjfldq10xkhcr6dfniwscxkjbrfkd8mbm3327xgq3n0qjbis"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("ncurses"   ,ncurses)
+       ("libressl"  ,libressl)
+       ("libevent"  ,libevent)))
+    (arguments
+     `(#:tests? #f))
+    (synopsis "Gemini client with a terminal interface")
+    (description "Gemini client with a terminal interface")
+    (home-page "https://git.omarpolo.com/telescope/about/")
+    (license license:x11)))