diff mbox series

[bug#46923] - added copyright notice from buildapp.

Message ID YED1b2+iiCTkiZBK@kurosawa.casa.net
State Accepted
Headers show
Series [bug#46923] - added copyright notice from buildapp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

cage March 4, 2021, 2:57 p.m. UTC
---
 gnu/packages/web-browsers.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Tobias Geerinckx-Rice March 4, 2021, 8:56 p.m. UTC | #1
Cage,

cage 写道:
> added copyright notice from buildapp.

Could you explain the reason for this patch?

Thanks,

T G-R
Tobias Geerinckx-Rice March 4, 2021, 9:14 p.m. UTC | #2
Tobias Geerinckx-Rice via Guix-patches via 写道:
> Could you explain the reason for this patch?

OK, I see that 865728dd52600c7aa29a87bf18cb02ddf453cdfc adds a 
line that was inspired by [0].

A copyright line isn't required in this case, because IMO it falls 
(far) short of copyrightable significance.

Kind regards,

T G-R

[0]: https://github.com/xach/buildapp/blob/master/Makefile#L12
Tobias Geerinckx-Rice March 4, 2021, 9:35 p.m. UTC | #3
Tobias Geerinckx-Rice via Guix-patches via 写道:
> A copyright line isn't required in this case, because IMO it 
> falls
> (far) short of copyrightable significance.

For completeness: even if this were a significant hunk of code, we 
still wouldn't do this.

Guix is released under the GPLv3: even if some part(s) could be 
distributed under more permissive licences, we don't do so, and 
any modifications we make to these are released under the GPLv3 as 
well.  The result is a GPLv3 programme.  There's no need to add 
BSD or other licence headers in either case, although a copyright 
line might be required.

Hence I'm closing this bug, but thank you for submitting it!

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 5a83a4ef95..6f3041ffe6 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -31,6 +31,34 @@ 
 ;;;
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+;;;
+;;; Some code derived from buildapp:
+;;; Copyright (c) 2010 Zachary Beane, All Rights Reserved
+;;;
+;;; Redistribution and use in source and binary forms, with or without
+;;; modification, are permitted provided that the following conditions
+;;; are met:
+;;;
+;;;   * Redistributions of source code must retain the above copyright
+;;;     notice, this list of conditions and the following disclaimer.
+;;;
+;;;   * Redistributions in binary form must reproduce the above
+;;;     copyright notice, this list of conditions and the following
+;;;     disclaimer in the documentation and/or other materials
+;;;     provided with the distribution.
+;;;
+;;; THIS SOFTWARE IS PROVIDED BY THE AUTHOR 'AS IS' AND ANY EXPRESSED
+;;; OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+;;; WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+;;; ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
+;;; DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+;;; DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
+;;; GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+;;; INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+;;; WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+;;; NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+;;; SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+;;;
 
 (define-module (gnu packages web-browsers)
   #:use-module (guix build-system asdf)