diff mbox series

bug#46500: [PATCH] gnu: Add monado

Message ID YDaCDr+Dwj4hAiFh@jasmine.lan
State Accepted
Headers show
Series bug#46500: [PATCH] gnu: Add monado | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Leo Famulari Feb. 24, 2021, 4:42 p.m. UTC
On Sat, Feb 20, 2021 at 09:47:18PM -0800, Andy Tai wrote:
> review comments addressed;
> lint passed cleanly (except the one for Software Heritage)
> 
> install fixed and no error now

> From 99878cebc1e046369100cdae54d69dde3ade7448 Mon Sep 17 00:00:00 2001
> From: Andy Tai <atai@atai.org>
> Date: Sat, 20 Feb 2021 21:42:24 -0800
> Subject: [PATCH] gnu: Add monado
> 
> * gnu/packages/graphics.scm (monado): New variable

Thanks! I made the cosmetic changes shown below and pushed as
2fdc8ca7fdf6617835c48276585df6d5ace7c46e

Comments

Andy Tai Feb. 24, 2021, 7:02 p.m. UTC | #1
Awesome, thanks!

On Wed, Feb 24, 2021 at 8:42 AM Leo Famulari <leo@famulari.name> wrote:
>
> On Sat, Feb 20, 2021 at 09:47:18PM -0800, Andy Tai wrote:
> > review comments addressed;
> > lint passed cleanly (except the one for Software Heritage)
> >
> > install fixed and no error now
>
> > From 99878cebc1e046369100cdae54d69dde3ade7448 Mon Sep 17 00:00:00 2001
> > From: Andy Tai <atai@atai.org>
> > Date: Sat, 20 Feb 2021 21:42:24 -0800
> > Subject: [PATCH] gnu: Add monado
> >
> > * gnu/packages/graphics.scm (monado): New variable
>
> Thanks! I made the cosmetic changes shown below and pushed as
> 2fdc8ca7fdf6617835c48276585df6d5ace7c46e
>
> diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
> index 0b1c33401e..a76417a508 100644
> --- a/gnu/packages/graphics.scm
> +++ b/gnu/packages/graphics.scm
> @@ -1918,30 +1918,29 @@ Some feature highlights:
>  @end itemize\n")
>        (license license:gpl3+))))
>
> -
>  (define-public monado
>    (package
>      (name "monado")
>      (version "21.0.0")
> -        (source (origin
> -              (method url-fetch)
> -              (uri (string-append "https://gitlab.freedesktop.org/" name "/"
> -                                  name "/-/archive/v" version "/"
> -                                  name "-v" version ".tar.bz2"))
> -              (sha256
> -               (base32
> -                "0n04k7a8b0i8ga0kbzh7qxmvni1ijawgk98s83519vxg4d0yyjbq"))))
> +    (source (origin
> +          (method url-fetch)
> +          (uri (string-append "https://gitlab.freedesktop.org/" name "/"
> +                              name "/-/archive/v" version "/"
> +                              name "-v" version ".tar.bz2"))
> +          (sha256
> +           (base32
> +            "0n04k7a8b0i8ga0kbzh7qxmvni1ijawgk98s83519vxg4d0yyjbq"))))
>      (build-system meson-build-system)
>      (inputs
> -      `(("ffmpeg" ,ffmpeg)
> -        ("glslang" ,glslang)
> -        ("libudev" ,eudev)
> -        ("libusb" ,libusb)
> -        ("libxcb" ,libxcb)
> -        ("libxrandr" ,libxrandr)
> -        ("opengl" ,mesa)
> -        ("v4l" ,v4l-utils)
> -        ("vulkan-loader" ,vulkan-loader)))
> +     `(("ffmpeg" ,ffmpeg)
> +       ("glslang" ,glslang)
> +       ("libudev" ,eudev)
> +       ("libusb" ,libusb)
> +       ("libxcb" ,libxcb)
> +       ("libxrandr" ,libxrandr)
> +       ("opengl" ,mesa)
> +       ("v4l" ,v4l-utils)
> +       ("vulkan-loader" ,vulkan-loader)))
>      (native-inputs
>       `(("eigen" ,eigen)
>         ("pkg-config" ,pkg-config)
> @@ -1955,4 +1954,3 @@ Some feature highlights:
>  such as VR and AR on mobile, PC/desktop, and any other device.  Monado aims to be
>  a complete and conforming implementation of the OpenXR API made by Khronos.")
>      (license license:boost1.0)))
> -
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 0b1c33401e..a76417a508 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1918,30 +1918,29 @@  Some feature highlights:
 @end itemize\n")
       (license license:gpl3+))))
 
-
 (define-public monado
   (package
     (name "monado")
     (version "21.0.0")
-        (source (origin
-              (method url-fetch)
-              (uri (string-append "https://gitlab.freedesktop.org/" name "/"
-                                  name "/-/archive/v" version "/"
-                                  name "-v" version ".tar.bz2"))
-              (sha256
-               (base32
-                "0n04k7a8b0i8ga0kbzh7qxmvni1ijawgk98s83519vxg4d0yyjbq"))))
+    (source (origin
+          (method url-fetch)
+          (uri (string-append "https://gitlab.freedesktop.org/" name "/"
+                              name "/-/archive/v" version "/"
+                              name "-v" version ".tar.bz2"))
+          (sha256
+           (base32
+            "0n04k7a8b0i8ga0kbzh7qxmvni1ijawgk98s83519vxg4d0yyjbq"))))
     (build-system meson-build-system)
     (inputs
-      `(("ffmpeg" ,ffmpeg)
-        ("glslang" ,glslang)
-        ("libudev" ,eudev)
-        ("libusb" ,libusb)
-        ("libxcb" ,libxcb)
-        ("libxrandr" ,libxrandr)
-        ("opengl" ,mesa)
-        ("v4l" ,v4l-utils)
-        ("vulkan-loader" ,vulkan-loader)))
+     `(("ffmpeg" ,ffmpeg)
+       ("glslang" ,glslang)
+       ("libudev" ,eudev)
+       ("libusb" ,libusb)
+       ("libxcb" ,libxcb)
+       ("libxrandr" ,libxrandr)
+       ("opengl" ,mesa)
+       ("v4l" ,v4l-utils)
+       ("vulkan-loader" ,vulkan-loader)))
     (native-inputs
      `(("eigen" ,eigen)
        ("pkg-config" ,pkg-config)
@@ -1955,4 +1954,3 @@  Some feature highlights:
 such as VR and AR on mobile, PC/desktop, and any other device.  Monado aims to be
 a complete and conforming implementation of the OpenXR API made by Khronos.")
     (license license:boost1.0)))
-