diff mbox series

[bug#46880] - added tooter library.

Message ID YD6gkEIfZDNTRQ2I@kurosawa.casa.net
State Accepted
Headers show
Series [bug#46880] - added tooter library. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

cage March 2, 2021, 8:31 p.m. UTC
---
 gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Guillaume Le Vaillant March 3, 2021, 8:55 a.m. UTC | #1
Patch pushed as 9e76de0460a02c4129bec9a9e44b4a9c93e090a1 with some
modifications.
I put "Cage <cage-dev@twistfold.it>" in the copyright line; tell me if
you want to change it.
Thanks.
cage March 3, 2021, 2:02 p.m. UTC | #2
On Wed, Mar 03, 2021 at 09:55:58AM +0100, Guillaume Le Vaillant wrote:

Hi!

> Patch pushed as 9e76de0460a02c4129bec9a9e44b4a9c93e090a1 with some
> modifications.
> I put "Cage <cage-dev@twistfold.it>" in the copyright line; tell me if
> you want to change it.

This line is fine for me! Thank you, i forgot to add it in the patch.

Bye!
C.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 12852f7eb7..15919dc8d8 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -14680,3 +14680,37 @@  attributes not supported by the Common Lisp standard functions.")
 
 (define-public cl-file-attributes
   (sbcl-package->cl-source-package sbcl-file-attributes))
+
+(define-public sbcl-tooter
+  (let ((commit "b8d4b245b1d946bc9da6f51a3d8c2dc43e4d3868")
+        (revision "1"))
+    (package
+      (name "sbcl-tooter")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Shinmera/tooter")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0g40dlis4dbw4p3zxz3scx27b9zm8zlzihywapf5zqrdqfx5hpq9"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:asd-systems '("tooter")))
+      (inputs
+       `(("sbcl-yason"                ,sbcl-yason)
+         ("sbcl-cl-ppcre"             ,sbcl-cl-ppcre)
+         ("sbcl-drakma"               ,sbcl-drakma)
+         ("sbcl-documentation-utils"  ,sbcl-documentation-utils)))
+      (synopsis "Common Lisp client library for Mastodon instances")
+      (description "A Common Lisp client library for Mastodon instances.")
+      (home-page "https://shinmera.github.io/tooter/")
+      (license license:zlib))))
+
+(define-public ecl-tooter
+  (sbcl-package->ecl-package sbcl-tooter))
+
+(define-public cl-tooter
+  (sbcl-package->cl-source-package sbcl-tooter))