diff mbox series

[bug#61040] gnu: emacs-ergoemacs-mode: Include keyboard layout SVGs.

Message ID Y9D3eu7X5Hqn7DQt@sax
State New
Headers show
Series [bug#61040] gnu: emacs-ergoemacs-mode: Include keyboard layout SVGs. | expand

Commit Message

Ivan Vilata i Balaguer Jan. 25, 2023, 9:33 a.m. UTC
Nicolas Goaziou (2023-01-24 19:59:20 +0100) wrote:

> Ivan Vilata i Balaguer <ivan@selidor.net> writes:
> 
> > +    (arguments
> > +     (list #:phases #~(modify-phases %standard-phases
> > +                        (add-after 'install 'install-kbd-svgs
> > +                          (lambda _
> > +                            (let ((dir (elpa-directory #$output)))
> > +                              (install-file "kbd.svg" dir)
> > +                              (install-file "kbd-ergo.svg" dir)))))))
> 
> Please use #:include keyword for these files instead of this
> hand-crafted phase.

Thanks Nicolas, I didn't know about the keyword.  Attaching the updated patch.
Much simpler! 🙂

Salut !

Comments

Nicolas Goaziou Jan. 27, 2023, 8:34 a.m. UTC | #1
Hello,

Ivan Vilata i Balaguer <ivan@selidor.net> writes:

> Thanks Nicolas, I didn't know about the keyword.  Attaching the updated patch.
> Much simpler! 🙂

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ee115192f9..77ab0bc448 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -120,6 +120,7 @@ 
 ;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
 ;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
 ;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19974,6 +19975,9 @@  (define-public emacs-ergoemacs-mode
         (base32
          "1ipwzl0l26g5qvc1sgmz2ra5vn1j3hl0mnkgzpa3j4p8gsmxdiqr"))))
     (build-system emacs-build-system)
+    (arguments
+     (list #:include #~(cons* "^kbd\\.svg$" "^kbd-ergo\\.svg$"
+                              %default-include)))
     (propagated-inputs
      (list emacs-undo-tree))
     (home-page "https://ergoemacs.github.io/")