diff mbox series

[bug#61040] gnu: emacs-ergoemacs-mode: Include keyboard layout SVGs.

Message ID Y9AgYHwF0jflV3rZ@sax
State New
Headers show
Series [bug#61040] gnu: emacs-ergoemacs-mode: Include keyboard layout SVGs. | expand

Commit Message

Ivan Vilata i Balaguer Jan. 24, 2023, 6:16 p.m. UTC
A couple of SVG files from the source need to be installed to make
‘ergoemacs-theme-describe’ and ‘ergoemacs-layout-describe’ work.

* gnu/packages/emacs-xyz.scm (emacs-ergoemacs-mode)[arguments]: New field.
---
 gnu/packages/emacs-xyz.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Nicolas Goaziou Jan. 24, 2023, 6:59 p.m. UTC | #1
Hello,

Ivan Vilata i Balaguer <ivan@selidor.net> writes:

> A couple of SVG files from the source need to be installed to make
> ‘ergoemacs-theme-describe’ and ‘ergoemacs-layout-describe’ work.
>
> * gnu/packages/emacs-xyz.scm (emacs-ergoemacs-mode)[arguments]: New
> field.

Thank you.

> +    (arguments
> +     (list #:phases #~(modify-phases %standard-phases
> +                        (add-after 'install 'install-kbd-svgs
> +                          (lambda _
> +                            (let ((dir (elpa-directory #$output)))
> +                              (install-file "kbd.svg" dir)
> +                              (install-file "kbd-ergo.svg" dir)))))))

Please use #:include keyword for these files instead of this
hand-crafted phase.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 41a0ccf09e..ec8dffc3e5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -120,6 +120,7 @@ 
 ;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
 ;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
 ;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19952,6 +19953,13 @@  (define-public emacs-ergoemacs-mode
         (base32
          "1ipwzl0l26g5qvc1sgmz2ra5vn1j3hl0mnkgzpa3j4p8gsmxdiqr"))))
     (build-system emacs-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-after 'install 'install-kbd-svgs
+                          (lambda _
+                            (let ((dir (elpa-directory #$output)))
+                              (install-file "kbd.svg" dir)
+                              (install-file "kbd-ergo.svg" dir)))))))
     (propagated-inputs
      (list emacs-undo-tree))
     (home-page "https://ergoemacs.github.io/")