diff mbox series

[bug#60702] gnu: weechat: Update to 3.8.

Message ID Y7yEwhJEmVlZMj5v@flashtux.org
State New
Headers show
Series [bug#60702] gnu: weechat: Update to 3.8. | expand

Commit Message

Sébastien Helleu Jan. 9, 2023, 9:18 p.m. UTC
* gnu/packages/irc.scm (weechat): Update to 3.8.
[arguments]: Do not build tests any more: since version 3.8, ‘make test’
is successful when tests are not built.
[native-inputs]: Remove dependency on cpputest as tests are not built
any more.
---
 gnu/packages/irc.scm | 11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)

Comments

宋文武 Jan. 12, 2023, 3:13 a.m. UTC | #1
Sébastien Helleu <flashcode@flashtux.org> writes:

> * gnu/packages/irc.scm (weechat): Update to 3.8.
> [arguments]: Do not build tests any more: since version 3.8, ‘make test’
> is successful when tests are not built.
> [native-inputs]: Remove dependency on cpputest as tests are not built
> any more.

Pushed, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 0a6c28980d..d850e9c916 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -195,14 +195,14 @@  (define-public irssi
 (define-public weechat
   (package
     (name "weechat")
-    (version "3.6")
+    (version "3.8")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://weechat.org/files/src/weechat-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1ppj676gwh67krq92xnfkmh3qnwbz8d51djsscxw013x7cdxg1cx"))))
+                "0a5zfkqqdkya111rl2gpwlbfala0305qry9cdz2r1h7q0316bjzp"))))
     (build-system cmake-build-system)
     (outputs '("out" "doc"))
     (native-inputs
@@ -210,9 +210,7 @@  (define-public weechat
        ("pkg-config" ,pkg-config)
        ,@(if (target-x86?)
            `(("ruby-asciidoctor" ,ruby-asciidoctor))
-           '())
-       ;; For tests.
-       ("cpputest" ,cpputest)))
+           '())))
     (inputs
      (list aspell
            curl
@@ -234,8 +232,7 @@  (define-public weechat
              ,@(if (target-x86?)
                  '("-DENABLE_MAN=ON"
                    "-DENABLE_DOC=ON")
-                '())
-             "-DENABLE_TESTS=ON")       ; ‘make test’ fails otherwise
+                '()))
        #:phases
        (modify-phases %standard-phases
          ,@(if (target-x86?)