diff mbox series

[bug#59933] gnu: Add go-git-sr-ht-adnano-go-gemini

Message ID Y5Oto1m6qlJR4Z1n@theoden
State New
Headers show
Series [bug#59933] gnu: Add go-git-sr-ht-adnano-go-gemini | expand

Commit Message

Christopher Howard Dec. 9, 2022, 9:50 p.m. UTC
This patch adds go-git-sr-ht-adnano-go-gemini to golang.scm.

The importer gave "go-git-sr-ht--adnano-go-gemini", but a single dash seems to be the convention for similar definitions in golang.scm.

Comments

Nicolas Goaziou April 23, 2023, 3:10 p.m. UTC | #1
Hello,

Christopher Howard <christopher@librehacker.com> writes:

> This patch adds go-git-sr-ht-adnano-go-gemini to golang.scm.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 70ddef52f1..3013e158d6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -38,6 +38,7 @@ 
 ;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 Christopher Howard <christopher@librehacker.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -9599,6 +9600,30 @@  (define-public go-github-com-pborman-getopt
 programs that use traditional command lines.")
     (license license:bsd-3)))
 
+(define-public go-git-sr-ht-adnano-go-gemini
+  (package
+    (name "go-git-sr-ht-adnano-go-gemini")
+    (version "0.2.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~adnano/go-gemini")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0mv4x4cfwyhh77wfb3r221bhr84x4nmjpgysnvvjgmbnnafsgfns"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "git.sr.ht/~adnano/go-gemini"))
+    (propagated-inputs `(("go-golang-org-x-net" ,go-golang-org-x-net)
+                         ("go-golang-org-x-text" ,go-golang-org-x-text)))
+    (home-page "https://git.sr.ht/~adnano/go-gemini")
+    (synopsis "go-gemini")
+    (description
+     "Package gemini provides Gemini client and server implementations.")
+    (license license:expat)))
+
 (define-public go-git-sr-ht-sircmpwn-getopt
   (package
     (name "go-git-sr-ht-sircmpwn-getopt")