[bug#58673] Updated patch
Commit Message
From 139a7cfe0398bb4bbe904ec58887f681de177657 Mon Sep 17 00:00:00 2001
From: Matthew James Kraai <kraai@ftbfs.org>
Date: Thu, 20 Oct 2022 20:16:00 -0700
Subject: [PATCH] gnu: s3cmd: Fix program name in output.
* gnu/packages/python-xyz.scm (s3cmd)[arguments]: Add a new 'hide-wrapping
phase.
---
gnu/packages/python-xyz.scm | 9 +++++++++
1 file changed, 9 insertions(+)
Here's an updated patch that also fixes the command name in messages displayed
by s3cmd.
Comments
Hi,
Matthew James Kraai <kraai@ftbfs.org> skribis:
>>From 139a7cfe0398bb4bbe904ec58887f681de177657 Mon Sep 17 00:00:00 2001
> From: Matthew James Kraai <kraai@ftbfs.org>
> Date: Thu, 20 Oct 2022 20:16:00 -0700
> Subject: [PATCH] gnu: s3cmd: Fix program name in output.
>
> * gnu/packages/python-xyz.scm (s3cmd)[arguments]: Add a new 'hide-wrapping
> phase.
Applied, thanks!
@@ -16222,6 +16222,15 @@ (define-public s3cmd
(sha256
(base32 "0rdgwwmmp8mdxc84bxq6k9a7v7z2qgc3df47djzs2b84gw81dglx"))))
(build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'hide-wrapping
+ (lambda _
+ (substitute* "S3/MultiPart.py"
+ (("sys\\.argv\\[0\\]") "\"s3cmd\""))
+ (substitute* "s3cmd"
+ (("optparser\\.get_prog_name\\(\\)") "\"s3cmd\"")))))))
(inputs
(list python-dateutil
python-magic))