diff mbox series

[bug#49619,2/2] Add pirate-get

Message ID XnItfta1qBuzHN4Qry9ln_5BinMAFHH_e2lBuJIRyrni65GW8zdksUYEwqn69dj-1o_pLN8WMi13S0i5V--ayequIOtDz84D88Wqz6LKV10=@protonmail.com
State New
Headers show
Series [bug#49619,1/2] Add pirate-get | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 22, 2021, 12:22 p.m. UTC
And I guess control@debbugs.gnu.org is some kind of bot, right?
Here's the second patch:

---
In-Reply-To: <JuV3kXY4ae-0f4PzOqwU4h0_Vh24XCQbm0P3uWqIKZ_-_7hOqSjxqsSHPpVdGA1OPcVRuyq0GT5UNjV_a8ZrDHuaZmNbh81jQzI644BmQR8=@protonmail.com>
References: <JuV3kXY4ae-0f4PzOqwU4h0_Vh24XCQbm0P3uWqIKZ_-_7hOqSjxqsSHPpVdGA1OPcVRuyq0GT5UNjV_a8ZrDHuaZmNbh81jQzI644BmQR8=@protonmail.com>
From: Petr Hodina <phodina@protonmail.com>
Date: Sun, 18 Jul 2021 13:02:14 +0200
Subject: [PATCH v2 2/2] gnu: Add python-pirate-get
To: 49619@debbugs.gnu.org


--
2.31.1
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 020ba78401..a3b181cc30 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1779,6 +1779,33 @@  helpers.")
       displaying tabular data in a visually appealing ASCII table format.")
     (license license:bsd-3)))

+(define-public python-pirate-get
+  (package
+    (name "python-pirate-get")
+    (version "0.4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pirate-get" version))
+        (sha256
+          (base32
+            "07s5ss9dxccx1mip7pyga1fagywkqchxmzz55ng47ac9053ffxkq"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-colorama" ,python-colorama)
+        ("python-pyperclip" ,python-pyperclip)
+        ("python-veryprettytable"
+         ,python-veryprettytable)))
+    (home-page
+      "https://github.com/vikstrous/pirate-get")
+    (synopsis
+      "Command line interface for The Pirate Bay")
+    (description
+      "@code{pirate-get} is a convenient command line tool (inspired by APT)
+to speed up your trip to the Pirate Bay and get your completely legal
+torrents more quickly.")
+    (license license:gpl3)))
+
 (define-public python2-humanfriendly
   (let ((base (package-with-python2
                 (strip-python2-variant python-humanfriendly))))