diff mbox series

[bug#60435] gnu: Add giada.

Message ID X8A2B7nUmrnZvUkd4H4qZCNKyrndvxFWXT380wB8sgQMbCGA7sdxxD0va7dyMUHdlvUWea7tqQc8wU0oX6Pv9RRfIAcT93J7MESa3C4Sayw=@proton.me
State New
Headers show
Series [bug#60435] gnu: Add giada. | expand

Commit Message

Sughosha Dec. 30, 2022, 9:26 p.m. UTC
* gnu/packages/music.scm (giada): New public variable.
---
 gnu/packages/music.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Maxim Cournoyer March 21, 2023, 3:03 p.m. UTC | #1
Hi Sugosha,

Sughosha <Sughosha@proton.me> writes:

> * gnu/packages/music.scm (giada): New public variable.
> ---
>  gnu/packages/music.scm | 40 ++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 40 insertions(+)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 5be767a138..e15cf5efb7 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -156,6 +156,7 @@ (define-module (gnu packages music)
>    #:use-module (gnu packages perl-web)
>    #:use-module (gnu packages php)
>    #:use-module (gnu packages pkg-config)
> +  #:use-module (gnu packages pretty-print) ;for fmt
>    #:use-module (gnu packages protobuf)
>    #:use-module (gnu packages pulseaudio) ;libsndfile
>    #:use-module (gnu packages python)
> @@ -4059,6 +4060,45 @@ (define-public sooperlooper
>  available memory.")
>      (license license:gpl2+)))
>  
> +(define-public giada
> +  (package
> +    (name "giada")
> +    (version "0.23.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                     (url "https://github.com/monocasual/giada")
> +                     (commit (string-append "v" version))
> +                     ;; TODO: Use installed libraries.
> +                     (recursive? #t)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "01r7iz8s33cdiia3gxb6s1nb4h4fzc3sr8gv1is0axjqwzbmqg3c"))))
> +    (build-system cmake-build-system)
> +    (arguments (list #:tests? #f)) ;no test target
> +    (native-inputs (list imagemagick json-modern-cxx pkg-config))
> +    (inputs (list alsa-lib
> +                  fmt
> +                  hicolor-icon-theme
> +                  jack-1
> +                  libsamplerate
> +                  libsndfile
> +                  libx11
> +                  libxcursor
> +                  libxft
> +                  libxinerama
> +                  libxpm
> +                  libxrandr
> +                  pulseaudio
> +                  rtmidi))
> +    (home-page "https://giadamusic.com")
> +    (synopsis "Music production tool")
> +    (description
> +     "Giada is a music production tool featuring a sample player, loop machine,
> +song editor, live recorder, FX processor and MIDI controller.")
> +    (license license:gpl3+)))

Thanks for this work!  It seems Debian has done the hard un-bundling
work for 0.22.0 [0]; it'd be a shame not to reuse it.  Could you give it
a try?  It may involve adding a couple dependencies to Guix, such as
juce, which doesn't seem to be packaged.

[0]  https://sources.debian.org/src/giada/0.22.0-2/debian/patches/
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5be767a138..e15cf5efb7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -156,6 +156,7 @@  (define-module (gnu packages music)
   #:use-module (gnu packages perl-web)
   #:use-module (gnu packages php)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages pretty-print) ;for fmt
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages pulseaudio) ;libsndfile
   #:use-module (gnu packages python)
@@ -4059,6 +4060,45 @@  (define-public sooperlooper
 available memory.")
     (license license:gpl2+)))
 
+(define-public giada
+  (package
+    (name "giada")
+    (version "0.23.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/monocasual/giada")
+                     (commit (string-append "v" version))
+                     ;; TODO: Use installed libraries.
+                     (recursive? #t)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "01r7iz8s33cdiia3gxb6s1nb4h4fzc3sr8gv1is0axjqwzbmqg3c"))))
+    (build-system cmake-build-system)
+    (arguments (list #:tests? #f)) ;no test target
+    (native-inputs (list imagemagick json-modern-cxx pkg-config))
+    (inputs (list alsa-lib
+                  fmt
+                  hicolor-icon-theme
+                  jack-1
+                  libsamplerate
+                  libsndfile
+                  libx11
+                  libxcursor
+                  libxft
+                  libxinerama
+                  libxpm
+                  libxrandr
+                  pulseaudio
+                  rtmidi))
+    (home-page "https://giadamusic.com")
+    (synopsis "Music production tool")
+    (description
+     "Giada is a music production tool featuring a sample player, loop machine,
+song editor, live recorder, FX processor and MIDI controller.")
+    (license license:gpl3+)))
+
 (define-public moc
   (package
     (name "moc")