diff mbox series

[bug#47467] : Fix Blender missing Voxel Remesher

Message ID W97Uc0VcONvby3EkKJ7oW2PBIrK9qUudZ-ZO7V5q0W1V7CZFz9A0kv_1JbwEsmn_Zda1GwGr4STGEehVvV7kyz-DUZdIvMeVW2RqD_oNyVk=@elenq.tech
State Accepted
Headers show
Series [bug#47467] : Fix Blender missing Voxel Remesher | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ekaitz Zarraga April 21, 2021, 4:03 p.m. UTC
This is the new patch with the minimum changes.
I tested it and the voxel remesher works without issues.

Cheers!

Comments

Leo Famulari April 21, 2021, 4:19 p.m. UTC | #1
On Wed, Apr 21, 2021 at 04:03:20PM +0000, Ekaitz Zarraga wrote:
> This is the new patch with the minimum changes.
> I tested it and the voxel remesher works without issues.

Thanks!

> From 4c3705efbd24a63614ecfa964c661a503c8001a9 Mon Sep 17 00:00:00 2001
> From: Ekaitz Zarraga <ekaitz@elenq.tech>
> Date: Wed, 21 Apr 2021 17:59:32 +0200
> Subject: [PATCH] gnu: blender: Update dependencies
> 
>     * gnu/packages/graphics.scm (blender):
>     [inputs]: Add openvdb
>     [arguments]: Add configure flags for openvdb

I pushed as 823752646f4992efdd4162724b46e04dda8b660a after rewriting the
commit message to 1) have a descriptive title, 2) use complete sentences
and 3) Describe the changes in terms of code. As well as re-indenting.
diff mbox series

Patch

From 4c3705efbd24a63614ecfa964c661a503c8001a9 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Wed, 21 Apr 2021 17:59:32 +0200
Subject: [PATCH] gnu: blender: Update dependencies

    * gnu/packages/graphics.scm (blender):
    [inputs]: Add openvdb
    [arguments]: Add configure flags for openvdb
---
 gnu/packages/graphics.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index f9f19cc28d..ef3be67b25 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -527,6 +527,7 @@  typically encountered in feature film production.")
                "-DWITH_INSTALL_PORTABLE=OFF"
                "-DWITH_JACK=ON"
                "-DWITH_MOD_OCEANSIM=ON"
+               "-DWITH_OPENVDB=ON"
                "-DWITH_OPENSUBDIV=ON"
                "-DWITH_PYTHON_INSTALL=OFF"
                (string-append "-DPYTHON_LIBRARY=python" ,python-version)
@@ -582,6 +583,7 @@  typically encountered in feature film production.")
        ("pugixml" ,pugixml)
        ("python" ,python)
        ("python-numpy" ,python-numpy)
+       ("openvdb" ,openvdb)
        ("tbb" ,tbb)
        ("zlib" ,zlib)
        ("embree" ,embree)))
-- 
2.31.0