diff mbox series

[bug#41638] adds emacs-shell-pop

Message ID ViiENGdbn2PHs5V9rnlP1ttIqFmtDsBX5OfZeFg5nn7KLoprhH8ukiNqxYFMACXchIDtsUsLgmib92jGAhqLJ3MFicEYtP9rZ6JPYpZQF0o=@protonmail.com
State Accepted
Headers show
Series [bug#41638] adds emacs-shell-pop | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

guix--- via Guix-patches via June 1, 2020, 1:57 a.m. UTC
Hello,

The attached patch adds the emacs-shell-pop package.

Ryan Desfosses

Sent with [ProtonMail](https://protonmail.com) Secure Email.
diff mbox series

Patch

From aa35d2a4b690672d8fd1bfa2bf7ad17214e1a091 Mon Sep 17 00:00:00 2001
From: Ryan Desfosses <rdes@protonmail.com>
Date: Sun, 31 May 2020 18:48:44 -0400
Subject: [PATCH] * gnu/packages/emacs-xyz.scm (emacs-shell-pop): New variable

---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7c014cfd4c..072d851e17 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23159,3 +23159,28 @@  files.")
 sources.  It features syntax highlighting, autocompletion, preview of buffer
 or region and use of locally installed binaries.")
     (license license:gpl3+)))
+
+(define-public emacs-shell-pop
+  (let ((commit "4b4394037940a890a313d715d203d9ead2d156a6")
+        (revision "0"))
+(package
+  (name "emacs-shell-pop")
+  (version (git-version "0.64" revision commit))
+  (source
+    (origin
+      (method git-fetch)
+      (uri (git-reference
+             (url "https://github.com/kyagi/shell-pop-el.git")
+             (commit commit)))
+      (file-name (git-file-name name version))
+      (sha256
+        (base32 "0s77n6b9iw1x3dv91ybkpgy3zvqd12si7zw3lg0m2b6j1akrawsg"))))
+  (build-system emacs-build-system)
+  (home-page "https://github.com/kyagi/shell-pop-el")
+  (synopsis "Utility which helps with pop up shell buffer")
+  (description
+    "This is a utility which helps you pop up and pop out shell buffer
+window easily.  Four pre-set options are: @samp{shell}, @samp{terminal},
+@samp{ansi-term}, and @samp{eshell}.  You can also set your custom shell
+if you use other configuration.")
+  (license license:gpl3+))))
-- 
2.26.2