diff mbox series

[bug#52717] Add watchdogd

Message ID UkJDvWKAucgQGdJ6e2bYEdX3_sr5hji9swTubcJBWCgyJ7KtoJagOOTdmSYer6oTTvnZ539IIuX5DhKIfIZ7mt1aVODb9-XLBJIQnQVeil0=@protonmail.com
State Accepted
Headers show
Series [bug#52717] Add watchdogd | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Dec. 21, 2021, 9:25 p.m. UTC
Hi,

these patches add watchdogd utility to supervise the system - applicable both to server and embedded instances.

----
Petr

Comments

Mathieu Othacehe Dec. 23, 2021, 5:14 p.m. UTC | #1
Hey,

> +               (("/usr/bin/which") (string-append (assoc-ref inputs "which")
> +                                                  "/bin/which"))
> +               (("ls\"") (string-append (assoc-ref inputs "coreutils")
> +                                        "/bin/ls\"")))

I replaced those lines to use the search-input-file procedure, and
pushed the whole series.

Thanks,

Mathieu
Leo Famulari Dec. 23, 2021, 5:38 p.m. UTC | #2
On Thu, Dec 23, 2021 at 06:14:49PM +0100, Mathieu Othacehe wrote:
> 
> Hey,
> 
> > +               (("/usr/bin/which") (string-append (assoc-ref inputs "which")
> > +                                                  "/bin/which"))
> > +               (("ls\"") (string-append (assoc-ref inputs "coreutils")
> > +                                        "/bin/ls\"")))
> 
> I replaced those lines to use the search-input-file procedure, and
> pushed the whole series.

Hi Mathieu,

I want to point out that search-input-file does not do the same thing as
(assoc-ref inputs "foo").

We should consider search-input-file as a replacement for the WHICH
procedure, and use gexps like #$foo to replace (assoc-ref inputs "foo").
Mathieu Othacehe Dec. 26, 2021, 11:47 a.m. UTC | #3
Hello,

> I want to point out that search-input-file does not do the same thing as
> (assoc-ref inputs "foo").
>
> We should consider search-input-file as a replacement for the WHICH
> procedure, and use gexps like #$foo to replace (assoc-ref inputs "foo").

Using #$foo could be problematic when using package inheritance, as
explained by Ludo in the recent blog article.

This leaves us with #$(this-package-input foo) and "search-input-file"
as alternatives. Maybe we should promote the first one, but I see that
you have rightfully started a thread about that.

Thanks,

Mathieu
diff mbox series

Patch

From 56dd72045055c55cecdd360ccafc3ae2b4d30898 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 21 Dec 2021 22:20:01 +0100
Subject: [PATCH 2/3] gnu: Add libuev.

* gnu/packages/linux.scm (libuev): New variable.

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1fe3924ca2..1f57d9fe89 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4906,6 +4906,28 @@  (define-public libite
     (home-page "https://troglobit.com/projects/libite/")
     (license license:expat)))
 
+(define-public libuev
+  (package
+    (name "libuev")
+    (version "2.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/troglobit/libuev")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0ih82lxfdcq179kknzdl5c8vi1l0n5j7yh68y8f6kwsrm457paf7"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake libtool))
+    (synopsis "Lightweight event loop library for epoll family APIs")
+    (description "This package provides small event loop that wraps the
+epoll family of APIs.")
+    (home-page "https://troglobit.com/projects/libuev/")
+    (license license:expat)))
+
 (define-public libraw1394
   (package
     (name "libraw1394")
-- 
2.34.0