diff mbox series

[bug#47399] Add Google's Highway library.

Message ID UUAUg5kD6-7_1czhMcr49Ndcy_7ASpyyZUguRvSbB4YiLZqf0un7uXjEeAQbMlM05Zvo4by-4nW0xc-xmSadhjmf0um4hBFBy2YS4Zm56sA=@pm.me
State Accepted
Headers show
Series [bug#47399] Add Google's Highway library. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Isaac Young March 26, 2021, 1:56 a.m. UTC
Oops, I didn't include the patch.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Thursday, March 25, 2021 6:54 PM, Isaac Young <isyoung@pm.me> wrote:

> Hello,
>
> I would like to add Google's highway library (https://github.com/google/highway) to guix officially. Any feedback will be greately apperciated as this is my first public package.
>
> Thank you,
> Isaac Young
diff mbox series

Patch

From e01ee85800935100e513cdf4175f238ef77da1fd Mon Sep 17 00:00:00 2001
From: Isaac Young <isyoung@pm.me>
Date: Thu, 25 Mar 2021 18:17:28 -0600
Subject: [PATCH] Add Google's Highway library.

---
 gnu/packages/datastructures.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index f10a54d376..cb796b17e3 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -371,3 +371,27 @@  and tsl::robin_pg_set. The first two are faster and use a power of two growth
 policy, the last two use a prime growth policy instead and are able to cope
 better with a poor hash function.")
     (license license:expat)))
+
+(define-public google-highway
+  (package
+    (name "google-highway")
+    (version "0.11.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/google/highway")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1zz21pap5qy3a490xy0nqp1p20f9x7zkar3msj5z0155l5fpfr3b"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("googletest" ,googletest)))
+    (arguments
+     `(#:tests? #t
+       #:configure-flags '("-DHWY_SYSTEM_GTEST=ON")))
+    (home-page "https://github.com/google/highway")
+    (synopsis "Highway is a C++ library for SIMD.")
+    (description "Performance-portable, length-agnostic SIMD with runtime dispatch")
+    (license license:asl2.0)))
-- 
2.31.0