diff mbox series

[bug#51301] Add cl-redis and dependents

Message ID TwWZK4_-a5kuUSV0V8DpxKYWpapIN7YOXZoQAOtzJYPWXmBD8dxJk_wymqluJmkmzaJtLTPqbP4Gcuvpu1fZsZud2jwrSAPSJyzKRW6wjP8=@protonmail.com
State Accepted
Headers show
Series [bug#51301] Add cl-redis and dependents | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Charles Oct. 20, 2021, 4:51 a.m. UTC
Sharlatan, I'm tagging you here because this includes cl-rutils, and I saw that you were working on that some months ago. My solution to the problem .asd file is to just delete it since it seems it isn't referring to the right system anyway.

Comments

Guillaume Le Vaillant Oct. 21, 2021, 9:48 a.m. UTC | #1
Patches pushed as c0d672853a005fc625169f5c905d4562b9b33635 and following
with some modifications.
I also moved should-test to "lisp-check.scm" as it is a test framework.
There are test frameworks that are still in "lisp-xyz.scm", but we'll
move them to "lisp-check.scm" too eventually.
Thanks.
diff mbox series

Patch

From f810ad48bd8ec46ae50a5aeb5485e6122d7add7c Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Tue, 19 Oct 2021 23:44:53 -0500
Subject: [PATCH 2/4] gnu: Add cl-should-test.

* gnu/packages/lisp-xyz.scm (cl-should-test sbcl-should-test ecl-should-test):
New Variables.
---
 gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 9b383b6d6d..d5a6a7bbe0 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2417,6 +2417,39 @@  (define-public cl-lisp-unit
 (define-public ecl-lisp-unit
   (sbcl-package->ecl-package sbcl-lisp-unit))
 
+(define-public sbcl-should-test
+  (let ((commit "48facb9f9c07aeceb71fc0c48ce17fd7d54a09d4")
+        (revision "0"))
+    (package
+      (name "sbcl-should-test")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/vseloved/should-test")
+               (commit commit)))
+         (file-name (git-file-name "should-test" version))
+         (sha256
+          (base32 "1fqqa7lhf28qg60ji9libkylkcy747x576qpjn1y7c945j2fxmnm"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("cl-ppcre" ,sbcl-cl-ppcre)
+         ("local-time" ,sbcl-local-time)
+         ("osicat" ,sbcl-osicat)
+         ("rutils" ,sbcl-rutils/untested)))
+      (home-page "https://github.com/vseloved/should-test")
+      (synopsis "Minimal yet feature-rich Common Lisp test framework")
+      (description "SHOULD-TEST is methodology-agnostic and non-opinionated,
+i.e. it doesn't care what kind of test approach you'd like to take.")
+      (license license:expat))))
+
+(define-public cl-should-test
+  (sbcl-package->cl-source-package sbcl-should-test))
+
+(define-public ecl-should-test
+  (sbcl-package->ecl-package sbcl-should-test))
+
 (define-public sbcl-anaphora
   (package
     (name "sbcl-anaphora")
-- 
2.33.0