diff mbox series

[bug#46454] gnu: Update zfs.

Message ID TjDF-9t9w3P5lOPGXn4yxmF2mAWG7JqPd_RMNtsMB4Ydy_x3fy6IvmEu8-OL74PNEifrvRuIAsnaWVbt6g_36Mt3r7myiuI2aauXEL6hIoM=@protonmail.com
State Accepted
Headers show
Series [bug#46454] gnu: Update zfs. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

raid5atemyhomework Feb. 12, 2021, 2:23 a.m. UTC
Please prioritize, as this release fixes a (minor and low-probability) security issue: https://github.com/openzfs/zfs/issues/11474#issuecomment-775383738 Upstream even released this point release "early" in order to get this fix deployed, we should do same over in Guix.

Minimally tested with `guix build zfs`.  Given that the difference from 2.0.2 is very tiny (the only substantive change is the fix to the above issue, this point release only exists to fix that one issue), I expect no particular problems updating in Guix.



From 753ecc32252b8b7d3e806ed7a16b2771c6b78559 Mon Sep 17 00:00:00 2001
From: raid5atemyhomework <raid5atemyhomework@protonmail.com>
Date: Fri, 12 Feb 2021 10:09:56 +0800
Subject: [PATCH] gnu: Update zfs.

* gnu/packages/file-systems.scm (zfs): Update to 2.0.3.
---
 gnu/packages/file-systems.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

--
2.30.0

Comments

宋文武 Feb. 12, 2021, 5:57 a.m. UTC | #1
raid5atemyhomework <raid5atemyhomework@protonmail.com> writes:

> * gnu/packages/file-systems.scm (zfs): Update to 2.0.3.

Pushed, thank you!
Tobias Geerinckx-Rice Feb. 13, 2021, 3 p.m. UTC | #2
RAID,

On 2021-02-12 3:23, raid5atemyhomework via Guix-patches via wrote:
> Please prioritize, as this release fixes a (minor and low-probability)
> security issue:

Thank you very much for taking care of this!

To ensure that security updates stand out more, both on the list and in 
the commit log, please use our (de facto?) standard commit message 
format.

Instead of

     gnu: Update zfs.

write

     gnu: zfs: Update 2.0.3 [fixes CVE-0000-001].

or, if no CVE (or equivalent like TROVE) has yet been assigned:

     gnu: zfs: Update 2.0.3 [security fixes].

Also note the changes to the rest of the subject.

Using this exact format makes it easi(er) to grep/automate the git log.  
Everyone doing their own thing makes it hard.

Kind regards,

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.
Tobias Geerinckx-Rice Feb. 13, 2021, 4:18 p.m. UTC | #3
On 2021-02-13 16:00, Tobias Geerinckx-Rice via Guix-patches via wrote:
>     gnu: zfs: Update 2.0.3 [fixes CVE-0000-001].
                      ^^^
                       to

Kind regards,

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.
diff mbox series

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index b7321addd4..118e0d9faf 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -847,7 +847,7 @@  APFS.")
 (define-public zfs
   (package
     (name "zfs")
-    (version "2.0.2")
+    (version "2.0.3")
     (outputs '("out" "module" "src"))
     (source
       (origin
@@ -856,7 +856,7 @@  APFS.")
                               "/download/zfs-" version
                               "/zfs-" version ".tar.gz"))
           (sha256
-           (base32 "090b2pp0cgzkjcnbjf8ms28dah5dff8s04q31z62czapwiy0drdx"))))
+           (base32 "0fg5hz1yy2z5ah0hzjv3xy5vcg1c214rps90dr80lfkalx5gd506"))))
     (build-system linux-module-build-system)
     (arguments
      `(;; The ZFS kernel module should not be downloaded since the license