diff mbox series

[bug#61157] gnu: Add uwufetch.

Message ID T_L5ZP68uFQVEkBxiSKFeiSeaa0wnwnW9BKEO9TlrwUnUROlrixht-iH2ky73jf4ArVMJqEg5ggxicXlamstj8HCckKeMm6284v2HYGnvHM=@protonmail.com
State New
Headers show
Series [bug#61157] gnu: Add uwufetch. | expand

Commit Message

J. Sims Jan. 31, 2023, 6:49 p.m. UTC
Hello,

I believe this version of the patch should address all the concerns you raised.

On Tuesday, January 31st, 2023 at 08:19, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

> > + (license license:gpl3)))
> 
> License is actually GPL3+.

For future reference, where do I look to differentiate GPLv3 from GPLv3+? I do check that, but obviously I sometimes miss it.

Thanks,
Juli

Comments

Nicolas Goaziou Feb. 1, 2023, 9:21 p.m. UTC | #1
Hello,

"J. Sims via Guix-patches" via <guix-patches@gnu.org> writes:

> I believe this version of the patch should address all the concerns
> you raised.

It does. Thank you.

> For future reference, where do I look to differentiate GPLv3 from GPLv3+? I do check that, but obviously I sometimes miss it.

If you look into any ".c" source file, you will read:

  either version 3 of the License, or (at your option) any later version.

which basically means GPL3+.

> Subject: [PATCH] gnu: Add uwufetch.
>
> * gnu/packages/admin.scm (uwufetch): Add uwufetch.

Applied!

Regards,
diff mbox series

Patch

From 57c7e81d9d44a9e905e8a89714f05a9059f15226 Mon Sep 17 00:00:00 2001
From: Juliana Sims <jtsims@protonmail.com>
Date: Sun, 29 Jan 2023 15:44:48 -0600
Subject: [PATCH] gnu: Add uwufetch.

* gnu/packages/admin.scm (uwufetch): Add uwufetch.
---
 gnu/packages/admin.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5cea17d562..46b38ef053 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -55,6 +55,7 @@ 
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Juliana Sims <jtsims@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3944,6 +3945,48 @@  (define-public hyfetch
 you are running, what theme or icon set you are using, etc.")
     (license license:expat)))
 
+(define-public uwufetch
+  (package
+    (name "uwufetch")
+    (version "2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/TheDarkBug/uwufetch")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0s4pzaqmlq6rn54kgmlpcrc0sy3q5zn6lxh4448k9iimshljsjfs"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f ;no tests
+      #:make-flags
+      #~(list (string-append "DESTDIR=" #$output)
+              (string-append "ETC_DIR=" #$output "/etc")
+              (string-append "CC=" #$(cc-for-target)))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (add-before 'build 'path-source-paths
+            (lambda _
+              (substitute* "uwufetch.c"
+                (("(/usr(/local)?)(.*;)" all _ _ rest)
+                 (string-append #$output rest))))))))
+    (inputs (list lshw
+                  ;; viu XXX not yet packaged in Guix
+                  xwininfo))
+    (home-page "https://github.com/TheDarkBug/uwufetch")
+    (synopsis "Meme system info tool based on Nyan/UwU trend")
+    (description
+     "UwUFetch is a system information tool in the lineage of NeoFetch,
+PFetch, HyFetch, and the like.  It prints ASCII art of your system's logo as
+well as a summary of system information.  UwUFetch's unique contribution is the
+uwu-ification of various words used in the description.  For example, Guix
+becomes gUwUix.")
+    (license license:gpl3+)))
+
 (define-public screenfetch
   (package
     (name "screenfetch")

base-commit: 4eccb27b4c74a9112cbbad722d85558e9565f20b
-- 
2.39.1