diff mbox series

[bug#51046] gnu: Add rdate.

Message ID SUBY-hDCsK2thC0eX2cx2RQm84xwhff1uJL3k4YeoCYQLCyH-fzBm4vjIK_NW9x4_tvYoLRjm1b6XlbF1wY5yxe536ffvRJCTYvZNi7pKp0=@protonmail.com
State New
Headers show
Series [bug#51046] gnu: Add rdate. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Oct. 5, 2021, 10:45 p.m. UTC
* gnu/packages/time.scm (rdate): New variable.

--
2.32.0

Comments

Andreas Enge March 8, 2024, 9:43 a.m. UTC | #1
Thanks, phodina, for the patch, and Juliana, for undigging and
reviewing it! Given that the package looks unmaintained, I was a bit
hesitant, but since it still builds, why not add it; I took the liberty
to not wait for QA to build it out.

Before pushing, I changed the licence to gpl2+. Indeed, if later versions
are not explicitly excluded ("v2 only"), the GPL itself contains a clause
that implies "or later":

9. The Free Software Foundation may publish revised and/or new versions
of the General Public License from time to time.  Such new versions will
be similar in spirit to the present version, but may differ in detail to
address new problems or concerns.
Each version is given a distinguishing version number.  If the Program
specifies a version number of this License which applies to it and "any
later version", you have the option of following the terms and conditions
either of that version or of any later version published by the Free
Software Foundation.  If the Program does not specify a version number of
this License, you may choose any version ever published by the Free Software
Foundation.

Here it is also explicitly given in the source,
for instance there:
   https://github.com/njh/rdate/blob/main/src/rdate.c

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index df4b8ac6f5..351c990ce1 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -470,6 +470,30 @@  datetime type.")
 (define-public python2-aniso8601
   (package-with-python2 python-aniso8601))

+(define-public rdate
+  (let ((commit "91d84610e3695e90a884e2953908e95a856a9b74")
+        (revision "1"))
+    (package
+      (name "rdate")
+      (version (git-version "1.4" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/njh/rdate")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "002ryjq8gj1ml5la4v6dr3bh1zw5kxwy65rpziq8d2ccccarhv59"))))
+      (build-system gnu-build-system)
+      (native-inputs `(("autoconf" ,autoconf)
+                       ("automake" ,automake)))
+      (synopsis "Get date and time based on RFC 868")
+      (description "@code{rdate} connects to an RFC 868 time server over a TCP/IP
+network, printing the returned time and/or setting the system clock.")
+      (home-page "https://www.aelius.com/njh/rdate/")
+      (license license:gpl2))))
+
 (define-public datefudge
   (package
     (name "datefudge")