diff mbox series

[bug#35611,2/2] gnu: Allow building gcc with non-default libc.

Message ID SR06qX6GvJElwSOhwVRsSr_56vN_MGzzJkycuP41EBD-Q-J-uNkxcOxjHeVnYUuxu2KipPiIYLqvLI73D6v_2wL3S8P6dD1V4u-yjdxmCsQ=@carldong.me
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Carl Dong May 6, 2019, 10:34 p.m. UTC
* gnu/packages/base.scm (make-gcc-libc): New procedure, returns a gcc
  that targets a specified libc.
  (gcc-glibc-2.26, gcc-glibc-2.27): New public variables.
---
 gnu/packages/base.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

--
2.21.0

Comments

Ludovic Courtès May 12, 2019, 9:41 p.m. UTC | #1
Carl Dong <contact@carldong.me> skribis:

> * gnu/packages/base.scm (make-gcc-libc): New procedure, returns a gcc
>   that targets a specified libc.
>   (gcc-glibc-2.26, gcc-glibc-2.27): New public variables.

Nice, LGTM!

(I’ll push it along with patch #1.)
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index e33e3c52c8..5c0cd36c14 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1009,6 +1009,35 @@  with the Linux kernel.")
                   (("/bin/pwd") "pwd"))
                 #t))))))))

+(define (make-gcc-libc base-gcc libc)
+  "Return a GCC that targets LIBC."
+  (package (inherit base-gcc)
+           (name (string-append (package-name base-gcc) "-"
+                                (package-name libc) "-"
+                                (package-version libc)))
+           (arguments
+            (substitute-keyword-arguments
+             (ensure-keyword-arguments (package-arguments base-gcc)
+                                       '(#:implicit-inputs? #f))
+             ((#:make-flags flags)
+              `(let ((libc (assoc-ref %build-inputs "libc")))
+                 ;; FLAGS_FOR_TARGET are needed for the target libraries to receive
+                 ;; the -Bxxx for the startfiles.
+                 (cons (string-append "FLAGS_FOR_TARGET=-B" libc "/lib")
+                       ,flags)))))
+           (native-inputs
+            `(("libc" ,libc)
+              ("libc:static" ,libc "static")
+              ,@(append (package-inputs base-gcc)
+                        (fold alist-delete (%final-inputs) '("libc" "libc:static")))))
+           (inputs '())))
+
+(define-public gcc-glibc-2.27
+  (make-gcc-libc gcc glibc-2.27))
+
+(define-public gcc-glibc-2.26
+  (make-gcc-libc gcc glibc-2.26))
+
 (define-public (make-glibc-locales glibc)
   (package
     (inherit glibc)