diff mbox series

[bug#51476,v2] gnu: Add ascii.

Message ID SG2PR01MB21605AD05742CA5C0E8127BB8D8F9@SG2PR01MB2160.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#51476,v2] gnu: Add ascii. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Nov. 6, 2021, 7:02 a.m. UTC
* gnu/packages/shellutils.scm (ascii): New variable.
---
Changes relative to PATCH v1:
* Change name of custom phase.
* Edit synopsis.
* Edit description.

 gnu/packages/shellutils.scm | 39 +++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)


base-commit: 4fd12fb00d595b6f6a5d5cc734863f4c4bc5f46c

Comments

Ludovic Courtès Dec. 11, 2021, 10:33 p.m. UTC | #1
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

> * gnu/packages/shellutils.scm (ascii): New variable.

Finally applied…

> +++ b/gnu/packages/shellutils.scm
> @@ -38,6 +38,7 @@
>    #:use-module (guix build-system gnu)
>    #:use-module (guix build-system go)
>    #:use-module (guix build-system python)
> +  #:use-module (gnu packages)

… minus this line.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 6e64cee1da..c7fff9b4ed 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -38,6 +38,7 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
+  #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bison)
@@ -54,6 +55,44 @@ 
   #:use-module (gnu packages tmux)
   #:use-module (gnu packages vim))
 
+(define-public ascii
+  (package
+    (name "ascii")
+    (version "3.18")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.catb.org/~esr/ascii/"
+                                  "ascii-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0b87vy06s8s3a8q70pqavsbk4m4ff034sdml2xxa6qfsykaj513j"))))
+    (build-system gnu-build-system)
+    (arguments `(#:make-flags
+                 (list (string-append "CC=" ,(cc-for-target))
+                       (string-append "PREFIX=" %output))
+                 #:phases
+                 (modify-phases %standard-phases
+                   (delete 'configure)
+                   (add-before 'install 'create-directories
+                     (lambda* (#:key outputs #:allow-other-keys)
+                       (let* ((out (assoc-ref outputs "out"))
+                              (bin (string-append out "/bin"))
+                              (man1 (string-append out "/share/man/man1")))
+                         (mkdir-p bin)
+                         (mkdir-p man1)))))
+                 #:tests? #f))
+    (home-page "http://www.catb.org/~esr/ascii/")
+    (synopsis "ASCII name and synonym chart")
+    (description
+      "The @code{ascii} utility provides easy conversion between various byte
+representations and the American Standard Code for Information Interchange
+(ASCII) character table.  It knows about a wide variety of hex, binary, octal,
+Teletype mnemonic, ISO/ECMA code point, slang names, XML entity names, and
+other representations.  Given any one on the command line, it will try to
+display all others.  Called with no arguments it displays a handy small ASCII
+chart.")
+    (license license:bsd-2)))
+
 (define-public boxes
   (package
     (name "boxes")