diff mbox series

[bug#39818] gnu: Add emacs-ddskk.

Message ID RBSjADghVPemvtNv7mi9eAoMggKAs5j95fTjdEDP5xhK6NqrkrQV-6rpW9xWP-_dFZvsXwx86wqMI--1LDn6Akv1vo3cyv1ZbiFfGnePKY8=@tojo.tokyo
State Accepted
Headers show
Series [bug#39818] gnu: Add emacs-ddskk. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Masaya Tojo Feb. 28, 2020, 12:44 a.m. UTC
Hello.
* gnu/packages/emacs-xyz.scm (emacs-ddskk): New variable.

Comments

Nicolas Goaziou Feb. 29, 2020, 7:35 p.m. UTC | #1
Hello,

Masaya Tojo <masaya@tojo.tokyo> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ddskk): New variable.

Thank you!

> +(define emacs-ddskk

Wouldn't it be emacs-skk, since one need to (require 'skk)?

> +  (package
> +    (name "emacs-ddskk")
> +    (version "17.0.50")

Is it an unstable version? Latest release seems to be 16.3. If so, if
there is a strong reason to use it instead, we should give it in
a comment.

> +    (home-page "https://github.com/skk-dev/ddskk")

This should be at the end of the package definition, right above
`synopsis'.

> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url home-page)
> +             (commit "b7bf6fa0e0fbb562c27a887283627a8781de0a34")))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "1ysn73yysaxpm93y9d4g2hmnd7qhh6lv93wgkrdw1cx11xl1g7yk"))))
> +    (build-system emacs-build-system)
> +    (inputs `(("inetutils" ,inetutils)))
> +    (synopsis "Simple Kana to Kanji conversion program")
> +    (description "Daredevil SKK is a version of SKK (Simple Kana to Kanji
> + conversion program, an input method of Japanese) 

is a version of @acronym{SKK, Simple Kana to Kanji} conversion program,
an input method of Japanese.

> + maintained by the SKK development team at http://openlab.jp/skk.")

We may want to drop that part, not very useful in the package
description. However, if you keep it, it should be
@url{http://openlab.jp/skk}.

BTW, I cannot apply your patch. Could you send an updated revision with
the changes suggested above?

Regards,
Nicolas Goaziou March 3, 2020, 8:05 a.m. UTC | #2
Hello,

Masaya Tojo <masaya@tojo.tokyo> writes:

> I tried to build 16.3 version but it fail. The cause is that
> skk-lookup.el needs an external file and that skk-xemacs.el needs be
> xemacs. There ware fixed at 17.0.50 version. 
>
> After 17.x is released, I will apply all your suggestions and send
> patch again.

Another option is to re-send the package with the commit you chose,
along with a comment explaining why (e.g., exactly what you wrote
above), and update it later when 17.x is released.

WDYT?

Regards,
Nicolas Goaziou March 5, 2020, 6:26 p.m. UTC | #3
Hello,

Masaya Tojo <masaya@tojo.tokyo> writes:

> I resend new revision.

Thank you!

I applied your patch as 5d0f33c2ab9aa0cdc51a35525e895a603eac78ea, with
the following changes:

- I used a top-level `version' and `code-name' variables instead of
  using release commit.
- I specified that the input method was on Emacs in description.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a9b36dd882..116786d0d6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -60,6 +60,7 @@ 
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
+;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21667,3 +21668,26 @@  EXIF, XMP and IPTC.")
generate random passwords and insert them into the current buffer.  It also
supports generation of phonetic and numeric passwords.")
     (license license:artistic2.0)))
+
+(define emacs-ddskk
+  (package
+    (name "emacs-ddskk")
+    (version "17.0.50")
+    (home-page "https://github.com/skk-dev/ddskk")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit "b7bf6fa0e0fbb562c27a887283627a8781de0a34")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1ysn73yysaxpm93y9d4g2hmnd7qhh6lv93wgkrdw1cx11xl1g7yk"))))
+    (build-system emacs-build-system)
+    (inputs `(("inetutils" ,inetutils)))
+    (synopsis "Simple Kana to Kanji conversion program")
+    (description "Daredevil SKK is a version of SKK (Simple Kana to Kanji
+ conversion program, an input method of Japanese) maintained by the SKK
+ development team at http://openlab.jp/skk.")
+    (license license:gpl2+)))