diff mbox series

[bug#47403] gnu: Add hikari

Message ID QtrXQ1xslRewnN0c6rDSJSSE0zXC4Rppgl5_YQ6whDhW6jTgit5aWgOBrb7Wr3MDPxiLGHC3IxYIbpO-Uvk2NECExDIBrLz7wbUSjgyJ5k8=@protonmail.com
State Accepted
Headers show
Series [bug#47403] gnu: Add hikari | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

qblade March 26, 2021, 6:28 a.m. UTC
Empty Message

Comments

Nicolas Goaziou March 26, 2021, 1:47 p.m. UTC | #1
Hello,

qblade via Guix-patches via <guix-patches@gnu.org> writes:

> Subject: [PATCH] gnu: Add hikari.
>
> * gnu/packages/wm.scm (hikari): New variable.

Thank you. I applied your patch with the changes below.

> +    (inputs
> +     `(("wayland" ,wayland)
> +       ("wlroots" ,wlroots)
> +       ("libinput" ,libinput)
> +       ("cairo" ,cairo)
> +       ("pango" ,pango)
> +       ("libxkbcommon" ,libxkbcommon)
> +       ("libucl" ,libucl)
> +       ("pam" ,linux-pam)))

I sorted inputs alphabetically.

> +    (synopsis "Stacking Wayland compositor with additional tiling capabilities")

I slightly shortened the synopsis.

> +    (description "Stacking Wayland compositor with additional tiling
> +capabilities, it is heavily inspired by the Calm Window
> manager(cwm)")

I turned the description into full setences.

Regards,
diff mbox series

Patch

From 81b755f0e44cdf86a7e2af83f07939dc2d1376f2 Mon Sep 17 00:00:00 2001
From: qblade <qblade@protonmail.com>
Date: Fri, 26 Mar 2021 01:33:42 +0000
Subject: [PATCH] gnu: Add hikari.

* gnu/packages/wm.scm (hikari): New variable.
---
 gnu/packages/wm.scm | 52 +++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 3d85392394..a637bce602 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2400,3 +2400,55 @@  for wayland conceptually based on the X11 window manager
      (description "libucl implements a configuration language that is easy to
 read and write, and compatible with JSON.")
     (license license:bsd-2)))
+
+(define-public hikari
+  (package
+    (name "hikari")
+    (version "2.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hikari.acmelabs.space/releases/hikari-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1qsd1qb4bn24jh5658gxmfg6hk9p7g235gsbvnjrbfdjqsv8r6yz"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("bmake" ,bmake)
+       ("pkg-config" ,pkg-config)
+       ("wayland-protocols" ,wayland-protocols)))
+    (inputs
+     `(("wayland" ,wayland)
+       ("wlroots" ,wlroots)
+       ("libinput" ,libinput)
+       ("cairo" ,cairo)
+       ("pango" ,pango)
+       ("libxkbcommon" ,libxkbcommon)
+       ("libucl" ,libucl)
+       ("pam" ,linux-pam)))
+    (arguments
+     `(#:tests? #f ; no tests
+       #:make-flags
+       (list
+        (string-append "PREFIX=" (assoc-ref %outputs "out"))
+        (string-append "CC=" ,(cc-for-target))
+        "WITH_XWAYLAND=YES"
+        "WITH_SCREENCOPY=YES"
+        "WITH_LAYERSHELL=YES"
+        "WITH_VIRTUAL_INPUT=YES")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (replace 'build
+           (lambda* (#:key inputs outputs make-flags #:allow-other-keys)
+             (apply invoke "bmake" make-flags)))
+         (replace 'install
+           (lambda* (#:key inputs outputs make-flags #:allow-other-keys)
+             (apply invoke "bmake" "install" make-flags))))))
+    (home-page "https://hikari.acmelabs.space/")
+    (synopsis "Stacking Wayland compositor with additional tiling capabilities")
+    (description "Stacking Wayland compositor with additional tiling
+capabilities, it is heavily inspired by the Calm Window manager(cwm)")
+    (license license:bsd-2)))
-- 
2.31.0