diff mbox series

[bug#46685] started whatweb

Message ID QsBe-kUrTEiBlgbN194t0SKsgUaVS6cgxSXvmPNLUGM-1MJeUwWJs8YDdJEqex2ocLHxv6KeaOA2irbSdxOxY0Hmrcm5qNLKV09SWulCH4M=@protonmail.com
State New
Headers show
Series [bug#46685] started whatweb | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

rdes Feb. 21, 2021, 1:39 p.m. UTC
Hello,

I've attached the following patches looking for feedback on how to resolve the following error I get when running `./pre-inst-env guix build whatweb`.

#+begin_example
starting phase `replace-git-ls-files'
Backtrace:
8 (primitive-load "/gnu/store/dznkg7ciirpr9crslkn73cql4mk…")
In ice-9/eval.scm:
191:35 7 (_ _)
In guix/build/gnu-build-system.scm:
838:2 6 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
In ice-9/boot-9.scm:
1736:10 5 (with-exception-handler _ _ #:unwind? _ # _)
In srfi/srfi-1.scm:
857:16 4 (every1 #<procedure 7ffff3facae0 at guix/build/gnu-bui…> …)
In guix/build/gnu-build-system.scm:
847:30 3 (_ _)
In guix/build/ruby-build-system.scm:
72:2 2 (replace-git-ls-files #:source _)
45:8 1 (first-matching-file _)
In ice-9/boot-9.scm:
1669:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1669:16: In procedure raise-exception:
No files matching pattern: "\\.gemspec$"
#+end_example

Also, I wasn't sure if bundler-audit should be named ruby-bundler-audit. The bundler package didn't start with 'ruby-' so I left it off for bundler-audit as well, but can change it if it's wrong.

Both 'bundler-audit' and 'ruby-ippaddr' can be built without issues.

Thanks,
Ryan Desfosses

Sent with [ProtonMail](https://protonmail.com) Secure Email.
diff mbox series

Patch

From 97dff6693bf8bcda97189a3595e21997c1790e89 Mon Sep 17 00:00:00 2001
From: Ryan Desfosses <rdes@protonmail.com>
Date: Sat, 20 Feb 2021 14:06:53 -0500
Subject: [PATCH 1/3] gnu: Add ruby-ippaddr

* gnu/packages/ruby.scm (ruby-ipaddr): New variable.
---
 gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6c9583b3cf..ecca0b8bf4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12139,3 +12139,28 @@  multiple adapters, various log level combinations and message formatting
 options.")
     (home-page "https://github.com/rudionrails/yell")
     (license license:expat)))
+
+(define-public ruby-ipaddr
+  (package
+    (name "ruby-ipaddr")
+    (version "1.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ruby/ipaddr")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0df6y3k42ylaacfwyrpfs2z5bhz09fypvz8dw8s96h934y5swyph"))))
+    (build-system ruby-build-system)
+    (native-inputs
+     `(("ruby-rake" ,ruby-rake)
+       ("rbundler" ,bundler)
+       ("ruby-test-unit" ,ruby-test-unit)))
+    (synopsis "Class to manipulate an IP address")
+    (description "IPAddr provides a set of methods to manipulate
+an IP address.  Both IPv4 and IPv6 are supported.")
+    (home-page "https://github.com/ruby/ipaddr")
+    (license license:bsd-2)))
-- 
2.30.1