diff mbox series

[bug#39372] Chicken Scheme: Update version to 5.1.0 and add gcc-toolchain

Message ID QqFafxZYtwwXSB_SOIxOvKOK8Ur5AipiQx1nzTNqukKxPc3b4Gkd_YGZpR6m3mBR1L9OtNHX-sUSowyGDn5tTBhC-h2fRrHB98_8-8y4h58=@elenq.tech
State Accepted
Headers show
Series [bug#39372] Chicken Scheme: Update version to 5.1.0 and add gcc-toolchain | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ekaitz Zarraga Jan. 31, 2020, 4:22 p.m. UTC
Hi,

I made a patch for chicken-scheme according to this conversation in the help-guix mailing list:

https://lists.gnu.org/archive/html/help-guix/2020-01/msg00230.html

I pushed the version to 5.1.0 and added gcc-toolchain as a propagated-input as the conversation suggested. The reason is without the gcc-toolchain csc (the chicken compiler) is unable to deal with -lm (math library), which is not installed with the current chicken package.

The linked conversation suggests that gcc-toolchain is a fundamental part of chicken so it should be a dependency of it.

Sorry if I didn't follow the format, but I was unable to find a good contributing guide.

Best,

Ekaitz

Comments

Jonathan Brielmaier Feb. 1, 2020, 12:36 a.m. UTC | #1
On 31.01.20 17:22, Ekaitz at ElenQ Technology wrote:
> Sorry if I didn't follow the format, but I was unable to find a good contributing guide.

There is a section (and related ones) in the manual:
http://guix.gnu.org/manual/en/html_node/Submitting-Patches.html#Submitting-Patches

On the our blog, there is a nice tutorial (quite lengthy) how to start
packaging:
http://guix.gnu.org/blog/2018/a-packaging-tutorial-for-guix/

But nevertheless good work! I'll leave to someone more experienced to
decide if propagating gcc-toolchain is the right way here...

~Jonathan
Julien Lepiller Feb. 8, 2020, 5:44 p.m. UTC | #2
Hi,

I tried to apply and build your patch, but unfortunately it didn't
work. From a clean checkout, I cannot run make anymore after applying
the patch, and if I run make before applying your patch, then
./pre-inst-env guix build chicken also fails with:

error: gnu-make: unbound variable
hint: Did you forget a `use-modules' form?

error: googletest: unbound variable
hint: Did you forget a `use-modules' form?

error: bzip2: unbound variable
hint: Did you forget a `use-modules' form?

error: binutils: unbound variable
hint: Did you forget a `use-modules' form?

error: gcc-4.9: unbound variable
hint: Did you forget a `use-modules' form?

error: openmpi: unbound variable
hint: Did you forget a `use-modules' form?

error: perl-module-build: unbound variable
hint: Did you forget a `use-modules' form?

error: python2-numpy: unbound variable
hint: Did you forget a `use-modules' form?

guix build: warning: failed to load '(gnu packages chromium)':
Unbound variable: opus
error: unzip: unbound variable
hint: Did you forget a `use-modules' form?

error: curl: unbound variable
hint: Did you forget a `use-modules' form?

error: binutils: unbound variable
hint: Did you forget a `use-modules' form?

error: libuv: unbound variable
hint: Did you forget a `use-modules' form?

error: libdvdnav: unbound variable
hint: Did you forget a `use-modules' form?

error: perl: unbound variable
hint: Did you forget a `use-modules' form?

error: static-bash: unbound variable
hint: Did you forget a `use-modules' form?

error: java-plexus-container-default: unbound variable
hint: Did you forget a `use-modules' form?

error: openmpi: unbound variable
hint: Did you forget a `use-modules' form?

error: givaro: unbound variable
hint: Did you forget a `use-modules' form?

error: curl: unbound variable
hint: Did you forget a `use-modules' form?

error: xorg-server: unbound variable
hint: Did you forget a `use-modules' form?

guix build: error: chicken: unknown package



I suppose this is caused by a module loop or something between (gnu
packages scheme) and (gnu packages commencement). Maybe splitting (gnu
packages scheme) into two things (maybe a new (gnu packages chicken))
would solve the issue?
diff mbox series

Patch

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 1009896a70..f1d04bfa53 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
 ;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
+;;; Copyright © 2018 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -69,6 +70,7 @@ 
   #:use-module (gnu packages tls)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages libedit)
+  #:use-module (gnu packages commencement)
   #:use-module (srfi srfi-1)
   #:use-module (ice-9 match))
 
@@ -371,14 +373,14 @@  mashups, office (web agendas, mail clients, ...), etc.")
 (define-public chicken
   (package
     (name "chicken")
-    (version "5.0.0")
+    (version "5.1.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://code.call-cc.org/releases/"
                                   version "/chicken-" version ".tar.gz"))
               (sha256
                (base32
-                "15b5yrzfa8aimzba79x7v6y282f898rxqxfxrr446sjx9jwlpfd8"))))
+                "0jsbp3kp0134f318j3wpd1n85gf8qzh034fn198gvazsv2l024aw"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules ((guix build gnu-build-system)
@@ -401,6 +403,7 @@  mashups, office (web agendas, mail clients, ...), etc.")
 
        ;; Parallel builds are not supported, as noted in README.
        #:parallel-build? #f))
+    (propagated-inputs `(("gcc-toolchain", gcc-toolchain)))
     (home-page "http://www.call-cc.org/")
     (synopsis "R5RS Scheme implementation that compiles native code via C")
     (description