diff mbox series

[bug#56394] gnu: xl2tpd: Fix cross-compilation.

Message ID QSO5GzC00biELncNpcasxQCTIiU63DcL1FtTQNo5_ON093VKJy849MUmwqUyxu5teS4s__GMGgQlIIq7L3PxXJffxeBNDpslPkg6yDtJQg4=@jeandudey.tech
State Accepted
Headers show
Series [bug#56394] gnu: xl2tpd: Fix cross-compilation. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jean Pierre De Jesus DIAZ July 5, 2022, 9:30 a.m. UTC
Fixes cross-compilation and also updates (optionally) the version
of xl2tpd to 1.3.17, the changes between versions is minimal:

https://github.com/xelerance/xl2tpd/compare/v1.3.16..v1.3.17

—
Jean-Pierre De Jesus DIAZ

Comments

Ludovic Courtès July 17, 2022, 7:36 p.m. UTC | #1
Hi,

Jean Pierre De Jesus DIAZ <me@jeandudey.tech> skribis:

> From 511bb2155973e24767befe11ea9b9eb66641f075 Mon Sep 17 00:00:00 2001
> Message-Id: <511bb2155973e24767befe11ea9b9eb66641f075.1657013271.git.me@jeandudey.tech>
> In-Reply-To: <1baf2bb97ab79cd020718605131b0a087fa215b4.1657013271.git.me@jeandudey.tech>
> References: <1baf2bb97ab79cd020718605131b0a087fa215b4.1657013271.git.me@jeandudey.tech>
> From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
> Date: Tue, 5 Jul 2022 11:27:01 +0200
> Subject: [PATCH 2/2] gnu: xl2tpd: Update to 1.3.17.
>
> * gnu/packages/vpn.scm (xl2tpd)[version]: Update to 1.3.17.

Applied.

> From 1baf2bb97ab79cd020718605131b0a087fa215b4 Mon Sep 17 00:00:00 2001
> Message-Id: <1baf2bb97ab79cd020718605131b0a087fa215b4.1657012966.git.me@jeandudey.tech>
> From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
> Date: Tue, 5 Jul 2022 11:21:07 +0200
> Subject: [PATCH] gnu: xl2tpd: Fix cross-compilation.
>
> * gnu/packages/vpn.scm (xl2tpd): Fix cross-compilation.
>   [arguments]: Use G-Expressions and use `cc-for-target'.

Efraim pushed as similar change in
422e5d351378f494612b9d6a2be4c19e625eb75c.

Thanks,
Ludo’.
diff mbox series

Patch

From 1baf2bb97ab79cd020718605131b0a087fa215b4 Mon Sep 17 00:00:00 2001
Message-Id: <1baf2bb97ab79cd020718605131b0a087fa215b4.1657012966.git.me@jeandudey.tech>
From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
Date: Tue, 5 Jul 2022 11:21:07 +0200
Subject: [PATCH] gnu: xl2tpd: Fix cross-compilation.

* gnu/packages/vpn.scm (xl2tpd): Fix cross-compilation.
  [arguments]: Use G-Expressions and use `cc-for-target'.
---
 gnu/packages/vpn.scm | 28 +++++++++++++++-------------
 1 file changed, 15 insertions(+), 13 deletions(-)

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 23141e56a3..d239288d10 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -1175,19 +1175,21 @@  (define-public xl2tpd
                 "0is5ccrvijz0pfm45pfrlbb9y8231yz3c4zqs8mkgakl9rxajy6l"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags (list (string-append "PREFIX=" %output)
-                          "CC=gcc")
-       #:phases (modify-phases %standard-phases
-                  (delete 'configure) ;no configure script
-                  (add-before 'build 'setup-environment
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      (substitute* "l2tp.h"
-                        (("/usr/sbin/pppd")
-                         (search-input-file inputs "/sbin/pppd")))
-                      (setenv "KERNELSRC"
-                              (assoc-ref inputs "kernel-headers"))
-                      #t)))
-       #:tests? #f))                    ; no tests provided
+      (list #:make-flags
+            #~(list (string-append "PREFIX=" #$output)
+                    (string-append "CC=" #$(cc-for-target)))
+            #:phases
+            #~(modify-phases %standard-phases
+                (delete 'configure) ;; No configure script.
+                (add-before 'build 'setup-environment
+                  (lambda* (#:key inputs #:allow-other-keys)
+                    (substitute* "l2tp.h"
+                      (("/usr/sbin/pppd")
+                       (search-input-file inputs "/sbin/pppd")))
+                    (setenv "KERNELSRC"
+                      (assoc-ref inputs "kernel-headers"))
+                    #t)))
+            #:tests? #f))           ;; No tests provided.
     (inputs (list libpcap ppp))
     (home-page "https://www.xelerance.com/software/xl2tpd/")
     (synopsis "Layer 2 Tunnelling Protocol Daemon (RFC 2661)")
-- 
2.36.1