From b2fbb0f91fe4bcddb50ebd7accdd9c239b03a3b1 Mon Sep 17 00:00:00 2001
From: Luis Felipe <luis.felipe.la@protonmail.com>
Date: Tue, 23 Nov 2021 13:30:04 -0500
Subject: [PATCH] gnu: Add python-sodapy.
* gnu/packages/python-web.scm (python-sodapy): New variable.
---
gnu/packages/python-web.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)
@@ -46,6 +46,7 @@
;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6348,3 +6349,20 @@ (define-public python-flask-combo-jsonapi
Flask-RESTful to quickly build APIs that fit the complexity of existing
real-life projects with legacy data and diverse storage providers.")
(license license:expat)))
+
+(define-public python-sodapy
+ (package
+ (name "python-sodapy")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sodapy" version))
+ (sha256
+ (base32 "03ywf14fplgrz15ci6lvj1kmbrd0sghvcmjbnarx4036q7ph3rs4"))))
+ (build-system python-build-system)
+ (propagated-inputs `(("python-requests" ,python-requests)))
+ (home-page "https://github.com/xmunoz/sodapy")
+ (synopsis "Python library for the Socrata Open Data API")
+ (description "Python library for the Socrata Open Data API.")
+ (license license:expat)))
--
2.33.0