diff mbox series

[bug#39372] Chicken Scheme: Update version to 5.1.0 and add gcc-toolchain

Message ID Pod4njTh0oNnLtUyn240QVjYHM3CRpHq0MaYH7ZcxmP5JW53XkcYrLt6DVIz2Gd_lOfMhQLnA5MsaF0yHINsURh4PWZ3zW7tYNcLbX7RnJw=@elenq.tech
State Accepted
Headers show
Series [bug#39372] Chicken Scheme: Update version to 5.1.0 and add gcc-toolchain | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Ekaitz Zarraga Feb. 9, 2020, 2:11 p.m. UTC
> I suppose this is caused by a module loop or something between (gnu
> packages scheme) and (gnu packages commencement). Maybe splitting (gnu
> packages scheme) into two things (maybe a new (gnu packages chicken))
> would solve the issue?

I think it does. I made a new patch with that but I'm not sure if I did
everything right:



From a898269624da04cceb539e0b7ca929cfea23be4d Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Sun, 9 Feb 2020 15:08:41 +0100
Subject: [PATCH] Move chicken to a separate package

---
 gnu/local.mk             |  1 +
 gnu/packages/chicken.scm | 50 ++++++++++++++++++++++++++++++++++++++++
 gnu/packages/scheme.scm  | 41 --------------------------------
 3 files changed, 51 insertions(+), 41 deletions(-)
 create mode 100644 gnu/packages/chicken.scm

--
2.17.1

Comments

Julien Lepiller Feb. 9, 2020, 2:30 p.m. UTC | #1
Le Sun, 09 Feb 2020 14:11:09 +0000,
Ekaitz Zarraga <ekaitz@elenq.tech> a écrit :

> > I suppose this is caused by a module loop or something between (gnu
> > packages scheme) and (gnu packages commencement). Maybe splitting
> > (gnu packages scheme) into two things (maybe a new (gnu packages
> > chicken)) would solve the issue?  
> 
> I think it does. I made a new patch with that but I'm not sure if I
> did everything right:

This is almost correct. You should make it two patches: the first moves
chicken to its own module, the second updates it. Make sure to add the
licence in the new file with a copyright line for yourself. The commit
message should be:

gnu: chicken: Move to a separate module.

* gnu/packages/scheme.scm (chicken): Move to chicken.scm.
* gnu/packages/chicken.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

for the first patch and:

gnu: chicken: Update to 5.1.0.

* gnu/packages/chicken.scm (chicken): Update to 5.1.0.
[propagated-inputs]: Add gcc-toolchain.

for the second patch. This makes it clearer what happens. You can find
a lot of examples from 'git log'.

Since no other package depends on chicken, we're all good I think.
Ekaitz Zarraga Feb. 9, 2020, 3:54 p.m. UTC | #2
‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Sunday, February 9, 2020 3:30 PM, Julien Lepiller <julien@lepiller.eu> wrote:

> This is almost correct. You should make it two patches: the first moves
> chicken to its own module, the second updates it. Make sure to add the
> licence in the new file with a copyright line for yourself. The commit
> message should be:
>
> gnu: chicken: Move to a separate module.
>
> -   gnu/packages/scheme.scm (chicken): Move to chicken.scm.
> -   gnu/packages/chicken.scm: New file.
> -   gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
>
>     for the first patch and:
>
>     gnu: chicken: Update to 5.1.0.
>
> -   gnu/packages/chicken.scm (chicken): Update to 5.1.0.
>     [propagated-inputs]: Add gcc-toolchain.
>
>     for the second patch. This makes it clearer what happens. You can find
>     a lot of examples from 'git log'.
>
>     Since no other package depends on chicken, we're all good I think.
>

Oh thanks.
I'll add them to the thread right now.
Julien Lepiller Feb. 9, 2020, 8:01 p.m. UTC | #3
Le Sun, 09 Feb 2020 14:11:09 +0000,
Ekaitz Zarraga <ekaitz@elenq.tech> a écrit :

> > I suppose this is caused by a module loop or something between (gnu
> > packages scheme) and (gnu packages commencement). Maybe splitting
> > (gnu packages scheme) into two things (maybe a new (gnu packages
> > chicken)) would solve the issue?  
> 
> I think it does. I made a new patch with that but I'm not sure if I
> did everything right:
> 

Pushed as 2846aec2f7d53b9244ad55c1436437843287426a and
7f6cb6bbac181a11859283922037e374a82035db. Thank you!
Ekaitz Zarraga Feb. 9, 2020, 8:03 p.m. UTC | #4
‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Sunday, February 9, 2020 9:01 PM, Julien Lepiller <julien@lepiller.eu> wrote:
> Pushed as 2846aec2f7d53b9244ad55c1436437843287426a and
> 7f6cb6bbac181a11859283922037e374a82035db. Thank you!


Thank you for your time
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 64ad653542..d86b39cacb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -109,6 +109,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/check.scm			\
   %D%/packages/chemistry.scm			\
   %D%/packages/chez.scm				\
+  %D%/packages/chicken.scm				\
   %D%/packages/chromium.scm			\
   %D%/packages/ci.scm				\
   %D%/packages/cinnamon.scm			\
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
new file mode 100644
index 0000000000..070373e049
--- /dev/null
+++ b/gnu/packages/chicken.scm
@@ -0,0 +1,50 @@ 
+(define-module (gnu packages chicken)
+  #:use-module (gnu packages)
+  #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix download)
+  #:use-module ((guix licenses)
+                #:select (bsd-3))
+  #:use-module (gnu packages commencement))
+
+(define-public chicken
+  (package
+    (name "chicken")
+    (version "5.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://code.call-cc.org/releases/"
+                                  version "/chicken-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0jsbp3kp0134f318j3wpd1n85gf8qzh034fn198gvazsv2l024aw"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:modules ((guix build gnu-build-system)
+                  (guix build utils)
+                  (srfi srfi-1))
+
+       ;; No `configure' script; run "make check" after "make install" as
+       ;; prescribed by README.
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'check)
+         (add-after 'install 'check
+           (assoc-ref %standard-phases 'check)))
+
+       #:make-flags (let ((out (assoc-ref %outputs "out")))
+                      (list "PLATFORM=linux"
+                            (string-append "PREFIX=" out)
+                            (string-append "VARDIR=" out "/var/lib")))
+
+       ;; Parallel builds are not supported, as noted in README.
+       #:parallel-build? #f))
+    (propagated-inputs `(("gcc-toolchain", gcc-toolchain)))
+    (home-page "http://www.call-cc.org/")
+    (synopsis "R5RS Scheme implementation that compiles native code via C")
+    (description
+     "CHICKEN is a compiler for the Scheme programming language.  CHICKEN
+produces portable and efficient C, supports almost all of the R5RS Scheme
+language standard, and includes many enhancements and extensions.")
+    (license bsd-3)))
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 1009896a70..c891a77a18 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -368,47 +368,6 @@  applications in many fields such as multimedia (web galleries, music players,
 mashups, office (web agendas, mail clients, ...), etc.")
     (license gpl2+)))

-(define-public chicken
-  (package
-    (name "chicken")
-    (version "5.0.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://code.call-cc.org/releases/"
-                                  version "/chicken-" version ".tar.gz"))
-              (sha256
-               (base32
-                "15b5yrzfa8aimzba79x7v6y282f898rxqxfxrr446sjx9jwlpfd8"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:modules ((guix build gnu-build-system)
-                  (guix build utils)
-                  (srfi srfi-1))
-
-       ;; No `configure' script; run "make check" after "make install" as
-       ;; prescribed by README.
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (delete 'check)
-         (add-after 'install 'check
-           (assoc-ref %standard-phases 'check)))
-
-       #:make-flags (let ((out (assoc-ref %outputs "out")))
-                      (list "PLATFORM=linux"
-                            (string-append "PREFIX=" out)
-                            (string-append "VARDIR=" out "/var/lib")))
-
-       ;; Parallel builds are not supported, as noted in README.
-       #:parallel-build? #f))
-    (home-page "http://www.call-cc.org/")
-    (synopsis "R5RS Scheme implementation that compiles native code via C")
-    (description
-     "CHICKEN is a compiler for the Scheme programming language.  CHICKEN
-produces portable and efficient C, supports almost all of the R5RS Scheme
-language standard, and includes many enhancements and extensions.")
-    (license bsd-3)))
-
 (define-public scheme48
   (package
     (name "scheme48")