diff mbox series

[bug#52424] gnu: Add cgdb.

Message ID PU1PR01MB2155EDD803971E2C61580E6C8D729@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#52424] gnu: Add cgdb. | expand

Commit Message

Foo Chuan Wei Dec. 11, 2021, 8:09 a.m. UTC
* gnu/packages/debug.scm (cgdb): New variable.
---
 gnu/packages/debug.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: cfdf66e6bfc463b041965b64fc95174c90f046e0

Comments

Nicolas Goaziou Dec. 17, 2021, 8:29 a.m. UTC | #1
Hello,

Foo Chuan Wei <chuanwei.foo@hotmail.com> writes:

> * gnu/packages/debug.scm (cgdb): New variable.

Thank you.

I used new package style explained below, and applied your patch.

> +    (inputs
> +     `(("ncurses" ,ncurses)
> +       ("readline" ,readline)))

  (inputs
   (list ncurses readline))

> +    (native-inputs
> +     `(("flex" ,flex)
> +       ("texinfo" ,texinfo)))

  (native-inputs
   (list flex texinfo))

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index c95cd036e8..7e2e5863c1 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -60,6 +61,7 @@ 
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages serialization)
+  #:use-module (gnu packages texinfo)
   #:use-module (gnu packages virtualization)
   #:use-module (gnu packages xdisorg)
   #:use-module (ice-9 match)
@@ -756,6 +758,32 @@  smaller than that of other tools such as Valgrind, and it aims to be easier to
 use than similar tools like @command{mtrace}.")
     (license license:gpl2+)))
 
+(define-public cgdb
+  (package
+    (name "cgdb")
+    (version "0.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://cgdb.me/files/cgdb-" version ".tar.gz"))
+       (sha256
+        (base32 "1671gpz5gx5j0zga8xy2x7h33vqh3nij93lbb6dbb366ivjknwmv"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("ncurses" ,ncurses)
+       ("readline" ,readline)))
+    (native-inputs
+     `(("flex" ,flex)
+       ("texinfo" ,texinfo)))
+    (home-page "https://cgdb.github.io")
+    (synopsis "Console front-end to the GNU debugger")
+    (description
+     "@code{cgdb} is a lightweight curses (terminal-based) interface to the
+GNU Debugger (GDB).  In addition to the standard gdb console, cgdb provides a
+split screen view that displays the source code as it executes.  The keyboard
+interface is modeled after vim, so vim users should feel at home using cgdb.")
+    (license license:gpl2+)))
+
 (define-public mspdebug
   ;; Last official release was 24 July 2017
   (let ((commit "4c4d94e43bc4a18ecf82070ff81cd38dd5641e3b")