diff mbox series

[bug#52406] gnu: Add cl-geco.

Message ID PU1PR01MB2155CCED699FCD867E9FD39D8D719@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#52406] gnu: Add cl-geco. | expand

Commit Message

Foo Chuan Wei Dec. 10, 2021, 6:10 a.m. UTC
* gnu/packages/lisp-xyz.scm (cl-geco, ecl-geco, sbcl-geco): New
  variables.
---
 gnu/packages/lisp-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: e1973ae74beb2880c11593155849f43e23ef620c

Comments

Guillaume Le Vaillant Dec. 11, 2021, 9:52 a.m. UTC | #1
Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

> * gnu/packages/lisp-xyz.scm (cl-geco, ecl-geco, sbcl-geco): New
>   variables.

cl-geco is already in Guix; could you instead send a patch to update it?
Foo Chuan Wei Dec. 11, 2021, 2:49 p.m. UTC | #2
On 2021-12-11 09:52 +0000, Guillaume Le Vaillant wrote:
> cl-geco is already in Guix; could you instead send a patch to update it?

Here's the patch to update cl-geco to version 2.1.2:
https://lists.gnu.org/archive/html/guix-patches/2021-12/msg00518.html
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 635f8e48cb..8e5312608b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -19757,6 +19757,37 @@  Vernacular builds on Overlord and is inspired by Racket.")
 (define-public cl-vernacular
   (sbcl-package->cl-source-package sbcl-vernacular))
 
+(define-public sbcl-geco
+  (let ((commit "db13c9384491092975f46f6a837ccdc04681a93a")
+        (revision "1"))
+    (package
+      (name "sbcl-geco")
+      (version (git-version "2.1.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/gpwwjr/GECO")
+               (commit commit)))
+         (file-name (git-file-name "cl-geco" version))
+         (sha256
+          (base32 "1ncaf9ab7jz59zmga0p97blsjjb1m6db0qih57wipfhqdb5ylz17"))))
+      (build-system asdf-build-system/sbcl)
+      (home-page "https://github.com/gpwwjr/GECO")
+      (synopsis "Framework for prototyping genetic algorithms in Common Lisp")
+      (description
+       "Genetic Evolution through Combination of Objects (GECO) is an
+extensible, object-oriented framework for prototyping genetic algorithms in
+Common Lisp.  GECO makes extensive use of CLOS, the Common Lisp Object System,
+to implement its functionality.")
+      (license license:gpl2+))))
+
+(define-public cl-geco
+  (sbcl-package->cl-source-package sbcl-geco))
+
+(define-public ecl-geco
+  (sbcl-package->ecl-package sbcl-geco))
+
 (define-public sbcl-cmn
   (package
     (name "sbcl-cmn")