diff mbox series

[bug#51160] gnu: Add vim-mucomplete

Message ID PU1PR01MB2155B879049CA6A371D31F828DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#51160] gnu: Add vim-mucomplete | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Oct. 12, 2021, 2:55 p.m. UTC
* gnu/packages/vim.scm (vim-mucomplete): New variable.
---
 gnu/packages/vim.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 35aaf1fe10488ae9ed732fb2c383d09a70c109c0

Comments

Efraim Flashner Oct. 25, 2021, 8:15 a.m. UTC | #1
Thanks. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 92189b7094..c56a0d4a1e 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1069,3 +1069,30 @@  your code every time you make a change.  @code{Vim-slime} is an attempt at
 getting some of these features into Vim.  It works with any REPL and isn't tied
 to Lisp.")
       (license license:expat))))
+
+(define-public vim-mucomplete
+  (package
+    (name "vim-mucomplete")
+    (version "1.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/lifepillar/vim-mucomplete")
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+         (base32 "054g80n09mmxxlh8xaic29bn8bgn3clvv732rymljdyvbj1mlhwd"))))
+    (build-system copy-build-system)
+    (arguments
+      '(#:install-plan
+        '(("autoload" "share/vim/vimfiles/")
+          ("doc" "share/vim/vimfiles/")
+          ("plugin" "share/vim/vimfiles/"))))
+    (home-page "https://github.com/lifepillar/vim-mucomplete")
+    (synopsis "MUcomplete is a minimalist autocompletion plugin for Vim")
+    (description
+      "MUcomplete is an implementation of chained (fallback) completion,
+whereby several completion methods are attempted one after another until a
+result is returned.")
+    (license license:expat)))