diff mbox series

[bug#55619] gnu: smlnj: Fix use of Ctrl-c in sml REPL.

Message ID PU1PR01MB21558F43DCE101CA76C722DA8DD69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#55619] gnu: smlnj: Fix use of Ctrl-c in sml REPL. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei May 25, 2022, 1:44 a.m. UTC
* gnu/packages/sml.scm (smlnj): Fix use of Ctrl-c in sml REPL.
---
Related mailing list thread:
https://lists.gnu.org/archive/html/guix-devel/2022-05/msg00209.html
("Why does sh in the build environment ignore SIGINT and SIGQUIT?")


 gnu/packages/sml.scm | 20 ++++++++++++++++----
 1 file changed, 16 insertions(+), 4 deletions(-)


base-commit: d129d962e437fd215c5e9428fc1b26e2d72ffbda

Comments

Tobias Geerinckx-Rice June 5, 2022, 1:12 a.m. UTC | #1
Hi!

Thanks for the patch and the perfect comment.

The only thing I tweaked was the commit message, to reflect the 
‘what’ rather than (just) the ‘why’:

    * gnu/packages/sml.scm (smlnj): Replace INVOKE with SYSTEM
    which has more favourable signal dispositions.

Tested on a Guix System that could reproduce the original bug & 
pushed as 62da327848311a75723f16642c20d2925919237e.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/sml.scm b/gnu/packages/sml.scm
index 04411c02c3..94a65961d6 100644
--- a/gnu/packages/sml.scm
+++ b/gnu/packages/sml.scm
@@ -175,10 +175,22 @@  function interface, and a symbolic debugger.")
                        "sml.boot.amd64-unix/SMLNJ-BASIS/.cm/amd64-unix/basis-common.cm"))
 
              ;; Build.
-             (invoke "./config/install.sh" "-default"
-                     (if (string=? "i686-linux" ,(%current-system))
-                       "32"
-                       "64"))
+             ;; The `sml` executable built by this package somehow inherits the
+             ;; signal dispositions of the shell where it was built. If SIGINT
+             ;; is ignored in the shell, the resulting `sml` will also ignore
+             ;; SIGINT. This will break the use of Ctrl-c for interrupting
+             ;; execution in the SML/NJ REPL.
+             ;; Here, we use Guile's `system` procedure instead of Guix's
+             ;; `invoke` because `invoke` uses Guile's `system*`, which causes
+             ;; SIGINT and SIGQUIT to be ignored.
+             (let ((exit-code
+                     (system (string-append "./config/install.sh -default "
+                                            (if (string=? "i686-linux"
+                                                          ,(%current-system))
+                                              "32"
+                                              "64")))))
+               (unless (zero? exit-code)
+                 (error (format #f "Exit code: ~a" exit-code))))
 
              ;; Undo the binary patch.
              (for-each