diff mbox series

[bug#55018] gnu: Add wtime.

Message ID PU1PR01MB215577BF8244F7995FB2878E8DF29@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#55018] gnu: Add wtime. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei April 19, 2022, 7:26 a.m. UTC
* gnu/packages/task-management.scm (wtime): New variable.
---
 gnu/packages/task-management.scm | 36 ++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: 6b677f4299f38ea70e1852388086ee95c2c48622
diff mbox series

Patch

diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index c349081f01..17fb8c335e 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -242,6 +243,41 @@  to with the goal of improving your focus and enhancing your productivity.
 You can also use it to fall asleep in a noisy environment.")
     (license license:gpl3+)))
 
+(define-public wtime
+  (package
+    (name "wtime")
+    (version "0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/wtime/wtime/"
+                           version "/wtime_"
+                           (string-replace-substring version "." "_")
+                           ".tar.gz"))
+       (sha256
+        (base32 "1rp1sxas9wjc84fvr6x94ryl3r9w7jd0x5j1hbi9q7yrgfclp830"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (add-after 'unpack 'fix-man-path
+           (lambda _
+             (substitute* "Makefile"
+               (("/man1") "/share/man/man1")))))
+       #:tests? #f))  ; No "check" target.
+    (home-page "http://wtime.sourceforge.net")
+    (synopsis
+     "Command-line utility for tracking time spent working on arbitrary tasks")
+    (description
+     "@code{wtime} is a command-line utility for tracking time spent working on
+arbitrary tasks.  All the time data is saved in files residing in the
+@code{.wtimed} directory in the user's home directory.")
+    (license license:x11)))
+
 (define-public todoman
   (package
     (name "todoman")