diff mbox series

[bug#52515] gnu: Add rcshist.

Message ID PU1PR01MB21556DBDA9F4E8315CBC7FE38D769@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#52515] gnu: Add rcshist. | expand

Commit Message

Foo Chuan Wei Dec. 15, 2021, 3:40 p.m. UTC
* gnu/packages/version-control.scm (rcshist): New variable.
---
 gnu/packages/version-control.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: ddea65d8f540bf3cba660e75ed0ce4f98e6e13a2

Comments

Ludovic Courtès Dec. 20, 2021, 3:17 p.m. UTC | #1
Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

> * gnu/packages/version-control.scm (rcshist): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c430834c88..ef52c5b7f7 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2068,6 +2068,28 @@  annotated RCS file describes the revision and date in which each line was
 added to the file, and the author of each line.")
     (license license:gpl2+)))
 
+(define-public rcshist
+  (package
+    (name "rcshist")
+    (version "1.04-20190106")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "https://invisible-mirror.net/archives/rcshist/rcshist-"
+                   version ".tgz"))
+             (sha256
+              (base32
+               "01ab3xwgm934lxr8bm758am3vxwx4hxx7cc9prbgqj5nh30vdg1n"))))
+    (build-system gnu-build-system)
+    (home-page "https://invisible-island.net/rcshist/rcshist.html")
+    (synopsis "Display RCS change history")
+    (description
+     "The @code{rcshist} utility displays the complete revision history of a
+set of RCS files including log messages and patches.  It can also display the
+patch associated with a particular revision of an RCS file.")
+    (license (list license:bsd-2
+                   license:bsd-3))))  ; bsd_queue.h
+
 (define-public cvs
   (package
     (name "cvs")