diff mbox series

[bug#52079] gnu: Add conflict.

Message ID PU1PR01MB2155651E1AFA125935A4286F8D619@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#52079] gnu: Add conflict. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Nov. 24, 2021, 3:24 p.m. UTC
* gnu/packages/shellutils.scm (conflict): New variable.
---
 gnu/packages/shellutils.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 8452c5d1f44b6fb6456409d9c51a3a32a7860b9c

Comments

Nicolas Goaziou Jan. 14, 2022, 9:32 a.m. UTC | #1
Hello,

Foo Chuan Wei <chuanwei.foo@hotmail.com> writes:

> * gnu/packages/shellutils.scm (conflict): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 70443f5019..4e24a80cef 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -514,6 +514,35 @@  (define-public rig
 city, state, zip, or area code, it will check out.")
     (license license:gpl2+)))
 
+(define-public conflict
+  (package
+    (name "conflict")
+    (version "20210108")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "https://invisible-mirror.net/archives/conflict/conflict-"
+                   version ".tgz"))
+             (sha256
+              (base32
+               "0mls4climvp7v9hnc3zh01mh270kqcj797ng0xslwb027lipis4h"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-paths
+           (lambda _
+             (substitute* "run_test.sh"
+               (("PATH=\".:\\$BIN:/bin\"")
+                "PATH=\".:$BIN:$PATH\"")))))))
+    (home-page "https://invisible-island.net/conflict/conflict.html")
+    (synopsis "Displays conflicting filenames in your execution path")
+    (description
+     "@code{conflict} examines the user-specifiable list of programs, looking
+for instances in the user's path which conflict (i.e., the name appears in more
+than one point in the path).")
+    (license (license:x11-style "file://COPYING"))))
+
 (define-public renameutils
   (package
     (name "renameutils")