diff mbox series

[bug#52405] gnu: Add cl-zsort.

Message ID PU1PR01MB2155533D9CEB34639034AFB48D719@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#52405] gnu: Add cl-zsort. | expand

Commit Message

Foo Chuan Wei Dec. 10, 2021, 6:09 a.m. UTC
* gnu/packages/lisp-xyz.scm (cl-zsort, ecl-zsort, sbcl-zsort): New
  variables.
---
Note:
In ECL, `(zsort:counting-sort #(4 5 7 3 9 2 4 2 0 8 2 4 1 5 9) :ascend t)`
fails with:

Condition of type: SIMPLE-TYPE-ERROR
In function +, the value of the first argument is
  NIL
which is not of the expected type NUMBER

 gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: e1973ae74beb2880c11593155849f43e23ef620c

Comments

Guillaume Le Vaillant Dec. 11, 2021, 9:51 a.m. UTC | #1
Patch pushed as e9c6be11260b1487ee241855d8189e1441f6bf8d.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 635f8e48cb..0ac48db778 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -19868,6 +19868,40 @@  library inspired by @code{cl-data-format-validation} and WTForms validators.")
 (define-public ecl-restas
   (sbcl-package->ecl-package sbcl-restas))
 
+(define-public sbcl-zsort
+  (let ((commit "f6724a6fff7662a942195cedb0d7f00da59c74ed")
+        (revision "1"))
+    (package
+      (name "sbcl-zsort")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/jorgetavares/zsort")
+               (commit commit)))
+         (file-name (git-file-name "cl-zsort" version))
+         (sha256
+          (base32 "1vyklyh99712zsll4qi0m4mm8yb1nz04403vl8i57bjv5p5max49"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)))
+      (home-page "https://github.com/jorgetavares/zsort")
+      (synopsis "Collection of portable sorting algorithms in Common Lisp")
+      (description
+       "@code{zsort} is a collection of portable sorting algorithms.  Common
+Lisp provides the @code{sort} and @code{stable-sort} functions but these can
+have different algorithms implemented according to each implementation.  Also,
+the standard sorting functions might not be the best for a certain situations.
+This library aims to provide developers with more options.")
+      (license license:expat))))
+
+(define-public cl-zsort
+  (sbcl-package->cl-source-package sbcl-zsort))
+
+(define-public ecl-zsort
+  (sbcl-package->ecl-package sbcl-zsort))
+
 (define-public sbcl-cl-https-everywhere
   ;; No release.
   ;; Don't forget to update the https-everywhere input.