diff mbox series

[bug#51159] gnu: Add vim-nerdcommenter

Message ID PU1PR01MB21554E125A15BDCFAABBF9148DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#51159] gnu: Add vim-nerdcommenter | expand

Commit Message

Foo Chuan Wei Oct. 12, 2021, 2:13 p.m. UTC
* gnu/packages/vim.scm (vim-nerdcommenter): New variable.
---
 gnu/packages/vim.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 35aaf1fe10488ae9ed732fb2c383d09a70c109c0

Comments

Efraim Flashner Oct. 25, 2021, 7:03 a.m. UTC | #1
I see that the latest tag is several years old and there has been
continued development since then. Does it make sense to package a newer
commit?

Also, if you add all the patches to the bottom of the file then they all
conflict with each other and it makes it harder to apply them.

On Tue, Oct 12, 2021 at 02:13:20PM +0000, Foo Chuan Wei wrote:
> * gnu/packages/vim.scm (vim-nerdcommenter): New variable.
> ---
>  gnu/packages/vim.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
> 
> diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
> index 92189b7094..f668aa0867 100644
> --- a/gnu/packages/vim.scm
> +++ b/gnu/packages/vim.scm
> @@ -1069,3 +1069,29 @@ your code every time you make a change.  @code{Vim-slime} is an attempt at
>  getting some of these features into Vim.  It works with any REPL and isn't tied
>  to Lisp.")
>        (license license:expat))))
> +
> +(define-public vim-nerdcommenter
> +  (package
> +    (name "vim-nerdcommenter")
> +    (version "2.5.2")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +              (url "https://github.com/preservim/nerdcommenter")
> +              (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +         (base32 "0s862kzhvv9qpr7gxd3h52hczjvm55zyff5qn0z5095072pr3wjx"))))
> +    (build-system copy-build-system)
> +    (arguments
> +      '(#:install-plan
> +        '(("doc" "share/vim/vimfiles/")
> +          ("plugin" "share/vim/vimfiles/"))))
> +    (home-page "https://github.com/preservim/nerdcommenter")
> +    (synopsis "Vim plugin for easy commenting of code")
> +    (description
> +      "NERD commenter is a Vim plugin that provides many different commenting
> +operations and styles which are invoked via key mappings and a menu. These
> +operations are available for most filetypes.")
> +    (license license:cc0)))
> 
> base-commit: 35aaf1fe10488ae9ed732fb2c383d09a70c109c0
> -- 
> 2.25.1
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 92189b7094..f668aa0867 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1069,3 +1069,29 @@  your code every time you make a change.  @code{Vim-slime} is an attempt at
 getting some of these features into Vim.  It works with any REPL and isn't tied
 to Lisp.")
       (license license:expat))))
+
+(define-public vim-nerdcommenter
+  (package
+    (name "vim-nerdcommenter")
+    (version "2.5.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/preservim/nerdcommenter")
+              (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+         (base32 "0s862kzhvv9qpr7gxd3h52hczjvm55zyff5qn0z5095072pr3wjx"))))
+    (build-system copy-build-system)
+    (arguments
+      '(#:install-plan
+        '(("doc" "share/vim/vimfiles/")
+          ("plugin" "share/vim/vimfiles/"))))
+    (home-page "https://github.com/preservim/nerdcommenter")
+    (synopsis "Vim plugin for easy commenting of code")
+    (description
+      "NERD commenter is a Vim plugin that provides many different commenting
+operations and styles which are invoked via key mappings and a menu. These
+operations are available for most filetypes.")
+    (license license:cc0)))