diff mbox series

[bug#51910] gnu: Add cl-trivial-open-browser.

Message ID PU1PR01MB2155481E5D1C7A635D0B6C498D9A9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#51910] gnu: Add cl-trivial-open-browser. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Nov. 17, 2021, 5:43 a.m. UTC
* gnu/packages/lisp-xyz.scm (cl-trivial-open-browser,
  ecl-trivial-open-browser, sbcl-trivial-open-browser):
  New variables.
---
 gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: 02a67810e566e8402e0b927c81ae39391762767d

Comments

Guillaume Le Vaillant Nov. 19, 2021, 10:01 a.m. UTC | #1
Patch pushed as 03b146c45c5fe673eca6e423a860a0d4470d2109 with a modified
description.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4b17c173c9..5608222e96 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18686,6 +18686,38 @@  higher-level lispier interface.")
 (define-public ecl-cl-charms
   (sbcl-package->ecl-package sbcl-cl-charms))
 
+(define-public sbcl-trivial-open-browser
+  (let ((commit "7ab4743dea9d592639f15c565bfa0756e828c427")
+        (revision "1"))
+    (package
+      (name "sbcl-trivial-open-browser")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/eudoxia0/trivial-open-browser")
+               (commit commit)))
+         (file-name (git-file-name "trivial-open-browser" version))
+         (sha256
+          (base32 "0ixay1piq420i6adx642qhw45l6ik7rvgk52lyz27dvx5f8yqsdb"))))
+      (build-system asdf-build-system/sbcl)
+      (home-page "https://github.com/eudoxia0/trivial-open-browser")
+      (synopsis "Open a browser window from Common Lisp")
+      (description
+       "Open the browser to a URL, on any system.  By default, the library
+runs a shell command to open the browser on Windows, Linux and OS X.  You can
+customize this by setting the value of @code{*browser-function*} to a custom
+function that takes a URL as its argument and somehow opens the browser to
+that URL.")
+      (license license:expat))))
+
+(define-public cl-trivial-open-browser
+  (sbcl-package->cl-source-package sbcl-trivial-open-browser))
+
+(define-public ecl-trivial-open-browser
+  (sbcl-package->ecl-package sbcl-trivial-open-browser))
+
 (define-public sbcl-clinenoise
   (let ((commit "46e21f99d06a55d93eaa382cf652d55d457032ef")
         (revision "1"))