diff mbox series

[bug#51476] gnu: Add ascii

Message ID PU1PR01MB215547D3B5FECA6434FBE7768D879@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#51476] gnu: Add ascii | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Oct. 29, 2021, 8:05 a.m. UTC
* gnu/packages/shellutils.scm (ascii): New variable.
---
 gnu/packages/shellutils.scm | 39 +++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)


base-commit: ad39268cdf075f4c4eeb87ed78ce46ca6f817675
diff mbox series

Patch

diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 3ded0ee897..3fd9799cbf 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -37,6 +38,7 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
+  #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bison)
@@ -53,6 +55,43 @@ 
   #:use-module (gnu packages tmux)
   #:use-module (gnu packages vim))
 
+(define-public ascii
+  (package
+    (name "ascii")
+    (version "3.18")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.catb.org/~esr/ascii/"
+                                  "ascii-" version ".tar.gz"))
+              (sha256
+                (base32
+                  "0b87vy06s8s3a8q70pqavsbk4m4ff034sdml2xxa6qfsykaj513j"))))
+    (build-system gnu-build-system)
+    (arguments `(#:make-flags
+                 (list (string-append "CC=" ,(cc-for-target))
+                       (string-append "PREFIX=" %output))
+                 #:phases
+                 (modify-phases %standard-phases
+                   (delete 'configure)
+                   (add-before 'install 'create-bin-directory
+                     (lambda* (#:key outputs #:allow-other-keys)
+                       (let* ((out (assoc-ref outputs "out"))
+                              (bin (string-append out "/bin"))
+                              (man1 (string-append out "/share/man/man1")))
+                         (mkdir-p bin)
+                         (mkdir-p man1)))))
+                 #:tests? #f))
+    (home-page "http://www.catb.org/~esr/ascii/")
+    (synopsis "List ASCII idiomatic names and octal/decimal code-point forms")
+    (description
+      "Provides easy conversion between various byte representations and the
+American Standard Code for Information Interchange (ASCII) character table. It
+knows about a wide variety of hex, binary, octal, Teletype mnemonic, ISO/ECMA
+code point, slang names, XML entity names, and other representations. Given any
+one on the command line, it will try to display all others. Called with no
+arguments it displays a handy small ASCII chart.")
+    (license license:bsd-2)))
+
 (define-public boxes
   (package
     (name "boxes")