diff mbox series

[bug#55535] gnu: Add apricots.

Message ID PU1PR01MB215527084F9B3FFE1C3F10A48DD39@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#55535] gnu: Add apricots. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei May 20, 2022, 4:15 a.m. UTC
* gnu/packages/games.scm (apricots): New variable.
---
 gnu/packages/games.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: cf17cbbc1b16dd15c8ec2e637d240de7ae5c3a44
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 37a245c570..32c8c27597 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12679,6 +12679,33 @@  Magic II (aka HOMM2) game engine.  It requires assets and game resources to
 play; it will look for them at @file{~/.local/share/fheroes2} folder.")
     (license license:gpl2)))
 
+(define-public apricots
+  (package
+    (name "apricots")
+    (version "0.2.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/moggers87/apricots")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0vis217hhnb9fbs9sf8mmcm71qp44kr3xqmffc1gdiixvi90c781"))
+       (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf  ; autom4te used in ./bootstrap
+                         automake  ; aclocal used in ./bootstrap
+                         cppcheck))
+    (inputs (list freealut
+                  openal
+                  sdl2))
+    (home-page "https://github.com/moggers87/apricots")
+    (synopsis "Arcade airplane game")
+    (description "@code {apricots} is a game where you fly a little plane around
+the screen and shoot things and drop bombs on enemy targets, and it's meant to
+be quick and fun.")
+    (license license:gpl2+)))
+
 (define-public liquidwar6
   (package
     (name "liquidwar6")